Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Database table locks
 
boxedrocket
Jr. Member
 
Total Posts:  6
Joined:  2013-05-15
 

We have a Magento community edition running Magento ver. 1.4.1.1.

We have started to notice a series of processes on MySQL that are hanging. A show processes command shows things like the following:

Query | 87 | Waiting for table level lock | INSERT INTO `report_viewed_product_index` (`visitor_id`, `customer_id`, `product_id`, `store_id`, `a |

Query | 87 | Waiting for table level lock | INSERT INTO `log_visitor` (`session_id`, `first_visit_at`, `last_visit_at`, `last_url_id`, `store_id |

Query | 85 | Waiting for table level lock | INSERT INTO `log_url_info` (`url`, `referer`) VALUES

Its causing real issues on the server, to the point where is makes the database server crash.

We have tried removing the various log tables, adding them back, truncating etc, but the issues soon reappear (sometimes hours, sometimes days).

Has anybody else experienced similar issues?

Many thanks
Cam

 
Magento Community Magento Community
Magento Community
Magento Community
 
Turnkeye
Enthusiast
 
Avatar
Total Posts:  908
Joined:  2008-12-20
URL: turnkeye.com
 

I recommend to adjust MySQL settings (including “Table Locking” settings) using tuning-primer script.

You can find instruction in our blog, here:

http://turnkeye.com/blog/magento-performance-optimize-mysql/

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

obviously your database is messed up,

could you please send us:
- storage engine for those tables
- database size
- your my.cnf

thank you

 
Magento Community Magento Community
Magento Community
Magento Community
 
boxedrocket
Jr. Member
 
Total Posts:  6
Joined:  2013-05-15
 

It appears the the query that is causing the issue starts with the following:

SELECT /*!40001 SQL_NO_CACHE */ * FROM `mg_log_visitor_info`

And the following:

SELECT /*!40001 SQL_NO_CACHE */ * FROM `sales_flat_shipment_grid`

Does anyone know whether we can switch off the logging completely, which will prevent our log tables from being so large?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

hi
you are looking at the wrong side of your problem,

please answer my question and also post an output of tuning-primer.sh

thank you

 
Magento Community Magento Community
Magento Community
Magento Community
 
boxedrocket
Jr. Member
 
Total Posts:  6
Joined:  2013-05-15
 

Thanks for the reply - see below for output of the tuning script:

MySQL Version 5.5.28-0ubuntu0.12.04.2 x86_64

Uptime = 6 days 23 hrs 54 min 47 sec
Avg. qps = 18
Total Questions = 11186035
Threads Connected = 9

Server has been running for over 48hrs.
It should be safe to follow these recommendations

To find out more information on how each of these
runtime variables effects performance visit:
http://dev.mysql.com/doc/refman/5.5/en/server-system-variables.html
Visit http://www.mysql.com/products/enterprise/advisors.html
for info about MySQL’s Enterprise Monitoring and Advisory Service

SLOW QUERIES
The slow query log is NOT enabled.
Current long_query_time = 10.000000 sec.
You have 1966 out of 11186056 that take longer than 10.000000 sec. to complete
Your long_query_time seems to be fine

BINARY UPDATE LOG
The binary update log is NOT enabled.
You will not be able to do point in time recovery
See http://dev.mysql.com/doc/refman/5.5/en/point-in-time-recovery.html

WORKER THREADS
Current thread_cache_size = 8
Current threads_cached = 4
Current threads_per_sec = 0
Historic threads_per_sec = 0
Your thread_cache_size is fine

MAX CONNECTIONS
Current max_connections = 150
Current threads_connected = 9
Historic max_used_connections = 76
The number of used connections is 50% of the configured maximum.
Your max_connections variable seems to be fine.

INNODB STATUS
Current InnoDB index space = 108 M
Current InnoDB data space = 135 M
Current InnoDB buffer pool free = 0 %
Current innodb_buffer_pool_size = 128 M
Depending on how much space your innodb indexes take up it may be safe
to increase this value to up to 2 / 3 of total system memory

MEMORY USAGE
Max Memory Ever Allocated : 380 M
Configured Max Per-thread Buffers : 403 M
Configured Max Global Buffers : 176 M
Configured Max Memory Limit : 579 M
Physical Memory : 2.94 G
Max memory limit seem to be within acceptable norms

KEY BUFFER
Current MyISAM index space = 195 K
Current key_buffer_size = 16 M
Key cache miss rate is 1 : 100
Key buffer free ratio = 81 %
Your key_buffer_size seems to be fine

QUERY CACHE
Query cache is enabled
Current query_cache_size = 16 M
Current query_cache_used = 10 M
Current query_cache_limit = 1 M
Current Query cache Memory fill ratio = 67.91 %
Current query_cache_min_res_unit = 4 K
MySQL won’t cache query results that are larger than query_cache_limit in size

SORT OPERATIONS
Current sort_buffer_size = 2 M
Current read_rnd_buffer_size = 256 K
Sort buffer seems to be fine

JOINS
Current join_buffer_size = 132.00 K
You have had 5570 queries where a join could not use an index properly
You should enable “log-queries-not-using-indexes”
Then look for non indexed joins in the slow query log.
If you are unable to optimize your queries you may want to increase your
join_buffer_size to accommodate larger joins in one pass.

Note! This script will still suggest raising the join_buffer_size when
ANY joins not using indexes are found.

OPEN FILES LIMIT
Current open_files_limit = 1024 files
The open_files_limit should typically be set to at least 2x-3x
that of table_cache if you have heavy MyISAM usage.
Your open_files_limit value seems to be fine

TABLE CACHE
Current table_open_cache = 400 tables
Current table_definition_cache = 400 tables
You have a total of 328 tables
You have 400 open tables.
Current table_cache hit rate is 0%
, while 100% of your table cache is in use
You should probably increase your table_cache

TEMP TABLES
Current max_heap_table_size = 16 M
Current tmp_table_size = 16 M
Of 2163931 temp tables, 27% were created on disk
Perhaps you should increase your tmp_table_size and/or max_heap_table_size
to reduce the number of disk-based temporary tables
Note! BLOB and TEXT columns are not allow in memory tables.
If you are using these columns raising these values might not impact your
ratio of on disk temp tables.

TABLE SCANS
Current read_buffer_size = 128 K
Current table scan ratio = 262 : 1
read_buffer_size seems to be fine

TABLE LOCKING
Current Lock Wait ratio = 1 : 417
You may benefit from selective use of InnoDB.
If you have long running SELECT’s against MyISAM tables and perform
frequent updates consider setting ‘low_priority_updates=1’
If you have a high concurrency of inserts on Dynamic row-length tables
consider setting ‘concurrent_insert=ALWAYS’.

 
Magento Community Magento Community
Magento Community
Magento Community
 
boxedrocket
Jr. Member
 
Total Posts:  6
Joined:  2013-05-15
 

Anyone else able to assist with this one?

Many thanks
C

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

- storage engine for those tables ??
innodb or myisam?

http://virtualizesharepoint.files.wordpress.com/2011/05/image40.png

 
Magento Community Magento Community
Magento Community
Magento Community
 
boxedrocket
Jr. Member
 
Total Posts:  6
Joined:  2013-05-15
 

InnoDB.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

ok, send us access details to check this out

 
Magento Community Magento Community
Magento Community
Magento Community
 
concubidated
Jr. Member
 
Total Posts:  1
Joined:  2012-07-10
 

Wondering if there was any update on this. I am having the same issue. Same time every night I get queries like this and takes 50 seconds for the page to load.

# Query_time: 50.749617 Lock_time: 0.000072 Rows_sent: 0 Rows_examined: 0
SET timestamp=1370671372;
INSERT INTO `log_visitor` (`session_id`, `first_visit_at`, `last_visit_at`, `last_url_id`, `store_id`) VALUES (\\\’ZxjskFTq81h0pa4N72qOS0\\\’, \\\’2013-06-08 06:02:01\\\’, \\\’2013-06-08 06:02:01\\\’, \\\’0\\\’, \\\’1\\\’);

UPDATE:

This was being caused from the Magento cron running.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kernowdesigns
Jr. Member
 
Total Posts:  1
Joined:  2008-05-21
 

Also Having the same issue, Any one got a solution?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top