Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Erreur d’installation : SQLSTATE[42000]: Syntax error or access violation: 1067 Invalid default value for ‘period‘“;i:1;s:922:”
 
youssef5
Jr. Member
 
Total Posts:  1
Joined:  2013-04-11
 

Bonjour.

Nous sommes en train d’installer Magento 1.7.0.1 sur serveur, et durant la phase 3 de l’installation une erreur s’affiche comme quoi --The requested URL /errors/report.php was not found on this server.-- et le contenu du rapport est :

a:5:{i:0;s:205:"Error in file: “/home/devproto/www/app/code/core/Mage/SalesRule/sql/salesrule_setup/upgrade-1.6.0.0-1.6.0.1.php” - SQLSTATE[42000]: Syntax error or access violation: 1067 Invalid default value for ‘period‘“;i:1;s:922:"#0 /home/devproto/www/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /home/devproto/www/app/code/core/Mage/Core/Model/Resource/Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘1.6.0.0’, ‘1.6.0.3’)
#2 /home/devproto/www/app/code/core/Mage/Core/Model/Resource/Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(’1.6.0.0’, ‘1.6.0.3’)
#3 /home/devproto/www/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/devproto/www/app/code/core/Mage/Core/Model/App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/devproto/www/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#6 /home/devproto/www/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#7 /home/devproto/www/index.php(87): Mage::run(’’, ‘store’)
#8 {main}”;s:3:"url”;s:29:"/~devproto/index.php/install/”;s:11:"script_name”;s:20:"/~devproto/index.php”;s:4:"skin”;s:7:"default";}

Si vous pouvez nous aider!!

et merci d’avance.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top