Magento Forum

   
wysiwyg not uploading images in backend
 
iamericlarson
Jr. Member
 
Total Posts:  19
Joined:  2012-03-25
 

So I’ve managed to complete my migration from localhost to Godaddys live server. All of the images weren’t working and the dropdown navigation in the admin panel wasn’t working also.

Live site: http://www.redrockoutdoorgear.com

I went into /media/.htaccess file and put a # sign at the beginning:

#Options All -Indexes
<IfModule mod_php5.c>
php_flag engine 0
</IfModule>

AddHandler cgi-script .php .pl .py .jsp .asp .htm .shtml .sh .cgi
Options 
-ExecCGI

<IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## never rewrite for existing files
    
RewriteCond %{REQUEST_FILENAME} !-f

############################################
## rewrite everything else to index.php

    
RewriteRule .* ../get.php [L]
</IfModule>

Which I was told would fix my problem with the images, but it fixed my problem with the drop javascript not working in the backend admin navigation.

Can anybody please help!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
GoMageTeam
Guru
 
Avatar
Total Posts:  356
Joined:  2013-01-13
Warsaw, Poland
 

Hello,

It can’t be said accurately, but we can advise you one variant. You have the parameter “merge js” enabled, that’s why JavaScript doesn’t work, please, try to do it:
Make sure that merge css an js is turned off. if you need to update this, you can edit it manually in the database by going into core_config_data, then find dev/js/merge_files and dev/css/merge_css_files, then set both of those to ‘0’.

 
Magento Community Magento Community
Magento Community
Magento Community
 
iamericlarson
Jr. Member
 
Total Posts:  19
Joined:  2012-03-25
 
GoMageTeam - 14 May 2013 06:40 AM

Hello,


It can’t be said accurately, but we can advise you one variant. You have the parameter “merge js” enabled, that’s why JavaScript doesn’t work, please, try to do it:
Make sure that merge css an js is turned off. if you need to update this, you can edit it manually in the database by going into core_config_data, then find dev/js/merge_files and dev/css/merge_css_files, then set both of those to ‘0’.

My javascript is merged by going to: System>Configuration> Developer>Javascript Settings>Merge Javascript Files>Yes

Going into the database will fix the wysiwyg uploading problems?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top