Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Apache settings for successful URL rewrites with Magento? 
 
freerange
Jr. Member
 
Total Posts:  5
Joined:  2008-02-22
 

I am running on a dedicated server and want to run my Magento installation with full URL rewrite capabilities. If I enable URL rewrites in the Magento admin (“Magento Admin” > System > Configuration > Web) I get the same page not found error as described on this thread:

http://www.magentocommerce.com/boards/viewthread/3002/

If I disable URL rewrites it works with the inclusion of URL/index.php/{request}

I have confirmed that URL rewrites are enabled and am able to redirect to other directories using URL rewrites (simple redirects added to .htaccess).

So, if I have confirmed that URL rewrites are working, is my server not returning the proper URI for the base url or some other problem? Any insights into what Magento is expecting with respect to system variables from the Apache server would be greatly appreciated.

Thanks again,
Derrick

 
Magento Community Magento Community
Magento Community
Magento Community
 
iblastoff
Sr. Member
 
Total Posts:  252
Joined:  2007-08-31
 

try refreshing your url rewrites in magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
freerange
Jr. Member
 
Total Posts:  5
Joined:  2008-02-22
 

Thanks for the idea. I just tried and am still getting the same results. I am wondering if there is anything that could be incorrectly setup in my apache settings. I know the rewrite works, but am wondering if base url or something else isn’t being reported correctly from the server.

It returns a 404 error, /home/gary/public_html/index.php was not found on this server

Let me know if you have any other ideas.

 
Magento Community Magento Community
Magento Community
Magento Community
 
freerange
Jr. Member
 
Total Posts:  5
Joined:  2008-02-22
 

FIXED

Looks like it had something to do with the fact that we had this site setup as a virtual host (we have multiple sites on this dedicated server). Since the virtual host was currently using a userdir, there are apparently known issues with mod_userdir. It probably would have worked fine once we propogated the DNS, but just moved it to a dedicated IP and it works.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top