Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

I have changed the Set Template attribute yet the layout does not change
 
roskolnikov
Member
 
Avatar
Total Posts:  31
Joined:  2008-01-02
Caribbean
 

I wanted to change the contact page from a 2 column right layout to a 1 column layout.
So in the contacts.xml i changed the following
from this:

<contacts_index_index>
<reference name="root">
<action method="setTemplate"><template>page/2columns-right.phtml</template></action>
<action method="setHeaderTitle" translate="title" module="contacts"><title>Contact Us</title></action>
</reference>
<reference name="content">
<block type="core/template" name="contactForm" template="contacts/form.phtml"/>
</reference>
</contacts_index_index>

to:

<contacts_index_index>
<reference name="root">
<action method="setTemplate"><template>page/1column.phtml</template></action>
<action method="setHeaderTitle" translate="title" module="contacts"><title>Contact Us</title></action>
</reference>
<reference name="content">
<block type="core/template" name="contactForm" template="contacts/form.phtml"/>
</reference>
</contacts_index_index>

and yet the contact page stays the same (2 column right layout) Please help me here as i have a project depending on this info to be successful.

Roskolnikov

 
Magento Community Magento Community
Magento Community
Magento Community
 
roskolnikov
Member
 
Avatar
Total Posts:  31
Joined:  2008-01-02
Caribbean
 

Hi ohminu,

I just checked and the contact page is not in the CMS. The contact function was recently included in the 8. whatever release.
Yea that’s why i think it warranted its own xml file.
Still open to suggestions

Roskolnikov

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bill007
Sr. Member
 
Avatar
Total Posts:  179
Joined:  2008-01-15
New Zealand
 

It has to mentioned Have you turned off the cache in the back end admin

This info could have saved 3 hours alone the caching system works great in fact to great because any changes with this Cache system enabled will not show the changes in the layout .xml file that you have uploaded also hitting ctrl f5 does not clear the cache

Step One Turn off all Caching in your demo store >>system>>cache management
Step Two Disable all cache controls except Configuration
Step Three Check Mark Refresh Cache

http://www.magentocommerce.com/boards/viewthread/2756/ for more info

 
Magento Community Magento Community
Magento Community
Magento Community
 
roskolnikov
Member
 
Avatar
Total Posts:  31
Joined:  2008-01-02
Caribbean
 

Thank You very Much,

I can finish my project now-this was great advice.

Cheers
Roskolnikov

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top