Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento not displaying SSL references in view source
 
areohdeee
Jr. Member
 
Total Posts:  2
Joined:  2011-04-06
 

When setting up the Magento back end to ‘Use SSL on Frontend’ and setting the unsecured url and secured url to https://xxxxxxxxxxxx.com/shop, if I view source Magento is not displaying the references with https:// thus giving insecure content warnings..

I’m at a loss to why this is happening.

<link rel="stylesheet" type="text/css" href="http://xxxxxxxxxxxxxx.com/shop/skin/frontend/default/default/css/styles.css" media="all" />
<link rel="stylesheet" type="text/css" href="http://xxxxxxxxxxxxxx.com/shop/skin/frontend/base/default/css/widgets.css" media="all" />
<link rel="stylesheet" type="text/css" href="http://xxxxxxxxxxxxxx.com/shop/skin/frontend/default/default/css/sidenav.css" media="all" />
<link rel="stylesheet" type="text/css" href="http://xxxxxxxxxxxxxx.com/shop/skin/frontend/default/default/css/sidenavcollapse.css" media="all" />
<link rel="stylesheet" type="text/css" href="http://xxxxxxxxxxxxxx.com/shop/skin/frontend/default/default/css/webtex/bubble.css" media="all" />
<link rel="stylesheet" type="text/css" href="http://xxxxxxxxxxxxxx.com/shop/skin/frontend/default/default/css/print.css" media="print" />
<script type="text/javascript\" src="http://xxxxxxxxxxxxxx.com/shop/js/prototype/prototype.js"></script>
<script type="text/javascript\" src="http://xxxxxxxxxxxxxx.com/shop/js/lib/ccard.js"></script>
<script type="text/javascript\" src="http://xxxxxxxxxxxxxx.com/shop/js/prototype/validation.js"></script>
<script type="text/javascript\" src="http://xxxxxxxxxxxxxx.com/shop/js/scriptaculous/builder.js"></script>
<script type="text/javascript\" src="http://xxxxxxxxxxxxxx.com/shop/js/scriptaculous/effects.js"></script>
<script type="text/javascript\" src="http://xxxxxxxxxxxxxx.com/shop/js/scriptaculous/dragdrop.js"></script>
<script type="text/javascript\" src="http://xxxxxxxxxxxxxx.com/shop/js/scriptaculous/controls.js"></script>

 
Magento Community Magento Community
Magento Community
Magento Community
 
areohdeee
Jr. Member
 
Total Posts:  2
Joined:  2011-04-06
 

Come to find out the server was not configured to share sessions correctly between http and https all is working now. Wooot!

 
Magento Community Magento Community
Magento Community
Magento Community
 
channelriyas
Jr. Member
 
Total Posts:  1
Joined:  2013-03-12
 

Hi areohdeee,

I also facing this same issue, could you please explain what you did in this situation, sorry I didnt get what you mean by this \” share sessions correctly on server\”.

It will be very helpful if you can explain what you did, on which etc...!

Thanks!
riyas

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 
channelriyas - 27 September 2013 11:54 PM

Hi areohdeee,

I also facing this same issue, could you please explain what you did in this situation, sorry I didnt get what you mean by this \” share sessions correctly on server\”.

It will be very helpful if you can explain what you did, on which etc...!

Thanks!
riyas

Try clearing both your cache and sessions files under the “/var/cache” and “/var/sessions” directory respectively.

Sometimes changes are not reflected until these are cleared.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top