Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

“PHP Extension “mcrypt” must be loaded” or “Pear error” or “no valid packages found”
 
Kaspar
Jr. Member
 
Total Posts:  3
Joined:  2008-02-23
 

Hi,

I downloaded Beta 0.8.16100 unpacked and uploaded to http://boxzy.co.uk. I changed the premissions for required folders and file and pointed my browser to boxzy.co.uk/install.

On third step “download updates” are many choices.
1) When I clicked “Continue SVN installation” then I got error: “PHP Extension “mcrypt” must be loaded”

2) When I clicked “Proceed with automatic download (beta)” then came at the end on the black area in green letters “PEAR ERROR: install failed” Got more errors before, so full text in green letters: http://boxzy.co.uk/green.txt

I didn’t undrestand if I have to chmod only the file and directories mentioned in installation guide or I should manually one-by-one chmod every single directory and file.

3) When I logged into shell then I got at the end “No valid packages found. install failed” Full shell process: http://boxzy.co.uk/shell.txt

I use Bytemark VPN hosting and Ubuntu is installed. I asked my server administrator if we have all the Magento requirements and he said yes. If something must be changed on server configuration then I can ask him to do it.

Thank you,

Kaspar

 
Magento Community Magento Community
Magento Community
Magento Community
 
Airforce111
Sr. Member
 
Avatar
Total Posts:  100
Joined:  2008-01-31
 

“PHP Extension “mcrypt” must be loaded” pretty much sums it up. You should double check whether your server meets the minimum requirements for Magento. You are missing mcrypt and you need to install it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
g4m3c4ck
Jr. Member
 
Total Posts:  20
Joined:  2008-02-01
 

I have Unbuntu 8.04 server installed here and I have the same mcyrpt issue when trying to run the install via pear. It says mcrypt is not found.

However, I have do have magento up and running.  I looked into it a little and Ubuntu does not support the php5-mcrypt package. I did find that I only had the mcrypt libaries and php5-mcrypt module installed but not the actual mcyrpt. I have not retried running the install with pear though. I will try it out later for you. In the meantime you may want to get your host to check that out as well.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top