Magento Forum

Blank Product Details after turning on flat catalog
 
cwchong
Jr. Member
 
Total Posts:  8
Joined:  2009-02-13
 

If i enable flat catalog, rebuild index and refresh the cache, my frontend product details page becomes blank, in particular, lines after $this->getChildHtml(’content’)

If i turn it off and refresh the cache, the details come up again

anyone else having this issue? this happens even if only the flat catalog (not product) is enabled

how do we tell if the cache is working properly? which fiile in var/cache should i be looking at?

 
Magento Community Magento Community
Magento Community
Magento Community
 
MikeL117
Jr. Member
 
Total Posts:  8
Joined:  2009-03-01
 

Hi

Yep, mine is also doing the same.

Not looked deep enough to see why, but it is happy (as far as I have checked so far) when Flat Cagalog is turned off.

Mike

 
Magento Community Magento Community
Magento Community
Magento Community
 
MassDigitalMedia
Sr. Member
 
Avatar
Total Posts:  83
Joined:  2009-02-19
Leominster, MA
 

Same issue here...I turned it off. Seems like a wasted “upgrade”...and I use that term loosely.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ogweewee
Member
 
Total Posts:  47
Joined:  2008-10-20
 

This was a bad April’s Fool joke.

 
Magento Community Magento Community
Magento Community
Magento Community
 
pdatoon
Sr. Member
 
Total Posts:  107
Joined:  2008-10-22
 

Same here :/

 
Magento Community Magento Community
Magento Community
Magento Community
 
MikeL117
Jr. Member
 
Total Posts:  8
Joined:  2009-03-01
 

As I suspected the problem I had was due to a minor incompatibility with one of the extensions I am running.
That is one of the risks of being an early adopter and why it is so important to not update your live site until you have got everything working on your test site.

In my case it was the “Customer Groups Configurable Catalog” extension that was somehow interfering with Magento finding the correct page with the products on when “flat catalog” was enabled.

Thanks to vinai-kung for updating his excellent extension so quickly.
http://www.magentocommerce.com/extension/reviews/module/635

For the others who have a similar problem I suggest you check through all your extensions to see if there is a likely culprit, if it is one that has attributes associated with it do NOT simply delete it - this will break Magento. But be pragmatic, switch off flat catalog until the extension has been updated, just don’t moan about it, tell about the problem so it can be fixed but really don’t whinge.

Remember a lot of these community extensions are still in beta so it is a real risk to use them in a live store, although often a very worthwhile risk.
Keep testing, it could be your money you are throwing away.

Thanks
Mike

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gabriel Queiroz
Sr. Member
 
Total Posts:  135
Joined:  2008-05-28
Brasília, Brazil
 

Had the same problem here. Fixed it by comparing the catalog.xml layout with the one from the new version. There has been modifications to the templates which were not on previous versions.

Cheers,

 
Magento Community Magento Community
Magento Community
Magento Community
 
geoz
Jr. Member
 
Total Posts:  10
Joined:  2008-12-12
 

I’ve got a similar problem. Some of the catelog pages come up, others simply don’t show any products, no apparent errors, just no products.

Switching off Flat Calalog fixes the problem - but of course I lose one of the key benefits of this upgrade. Tried clearing the cache - rebuilding etc - no joy. I have no extensions installed.

Has anyone else seen this problem and / or fixed it?

Gabriel - could you give some more details on what exact changes you needed to make to fix your system.

 
Magento Community Magento Community
Magento Community
Magento Community
 
geoz
Jr. Member
 
Total Posts:  10
Joined:  2008-12-12
 

OK, I have spent some time on this issue ( see post above ) and have fixed it for my installation. The syptoms for me were products not appearing on some of the Category pages. Disabling cache, rebuilding Flat Catelog sometimes led to different categories displaying products and others not. This inconsistant behaviour led me to believe that it was a caching issue.

Rebooting the server fixed the problem. I believe this was due to cacheing in apc or mysql causing a problem. Rebooting clears these caches automatically.

Hope this helps someone.

 
Magento Community Magento Community
Magento Community
Magento Community
 
M_CS
Member
 
Avatar
Total Posts:  44
Joined:  2010-06-08
San Jose
 

I am also facing same kind of error ,

I have installed featured product in my store, i can see the products in front end but my product detail page is empty i can’t see any product in detail page nor any right side blocks, i think there is some mess up with category that is why it is not taking proper url..

Help will be appreciated .

Mconnect
http://www.magentoconnect.us

 
Magento Community Magento Community
Magento Community
Magento Community
 
andreladocruz
Guru
 
Total Posts:  322
Joined:  2008-05-07
Brazil
 

Sirs,

I’m having the same problem here with magento 1.4.0.1

Even with the Flat Catalog desabled the product detail page is empty.

Any help on this?

Regards,

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top