Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 6
Login error after upgrade
 
rapi77
Jr. Member
 
Total Posts:  3
Joined:  2009-03-22
 

Hi,

I have upgraded to 1.3.0 through the magento manager.

After i log out and relogin , i get the following error.

Invalid method Mage_Adminhtml_Model_Url::useSecretKey(Array
(
)
)
Trace:
#0 [internal function]: Varien_Object->__call(’useSecretKey’, Array)
#1 /cust/stf1/xxxxx.com/wwwroot/shop/app/code/core/Mage/Admin/Model/Session.php(73): Mage_Adminhtml_Model_Url->useSecretKey()
#2 /cust/stf1/xxxxx.com/wwwroot/shop/app/code/core/Mage/Admin/Model/Observer.php(55): Mage_Admin_Model_Session->login(’xxxxxx’, ‘xxxxxxxx’, Object(Mage_Core_Controller_Request_Http))
#3 /cust/stf1/xxxxx.com/wwwroot/shop/app/code/core/Mage/Core/Model/App.php(1166): Mage_Admin_Model_Observer->actionPreDispatchAdmin(Object(Varien_Event_Observer))
#4 /cust/stf1/xxxxx.com/wwwroot/shop/app/Mage.php(301): Mage_Core_Model_App->dispatchEvent(’controller_acti...’, Array)
#5 /cust/stf1/xxxxx.com/wwwroot/shop/app/code/core/Mage/Core/Controller/Varien/Action.php(410): Mage::dispatchEvent(’controller_acti...’, Array)
#6 /cust/stf1/xxxxx.com/wwwroot/shop/app/code/core/Mage/Adminhtml/Controller/Action.php(131): Mage_Core_Controller_Varien_Action->preDispatch()
#7 /cust/stf1/xxxxx.com/wwwroot/shop/app/code/core/Mage/Core/Controller/Varien/Action.php(356): Mage_Adminhtml_Controller_Action->preDispatch()
#8 /cust/stf1/xxxxx.com/wwwroot/shop/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(247): Mage_Core_Controller_Varien_Action->dispatch(’index’)
#9 /cust/stf1/xxxxx.comwwwroot/shop/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#10 /cust/stf1/xxxxx.com/wwwroot/shop/app/Mage.php(457): Mage_Core_Controller_Varien_Front->dispatch()
#11 /cust/stf1/xxxxx.com/wwwroot/shop/index.php(52): Mage::run()
#12 {main}

Anyone has the same error? Any solutions to that?

 
Magento Community Magento Community
Magento Community
Magento Community
 
rogergerx
Jr. Member
 
Total Posts:  12
Joined:  2009-02-23
 

I’m having the same problem.
The site is blank and I can’t log into the admin after the upgrade.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rogergerx
Jr. Member
 
Total Posts:  12
Joined:  2009-02-23
 

Maybe I didn’t follow the proper procedure to upgrade: :<

-------------------------------------------------------------
just enter this as the extension key to install:
magento-core/Mage_All_Latest

from David
--------------------------------------------------------------

So some packages didn’t get upgraded. Any solution for manual upgrade?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ButterfliesForRelease
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2008-11-16
Brooker, FL
 

If you SSH into your server and change to the magento folder you can install the update with:
./pear install magento-core/Mage_All_Latest-stable

 
Magento Community Magento Community
Magento Community
Magento Community
 
rogergerx
Jr. Member
 
Total Posts:  12
Joined:  2009-02-23
 

Thanks. Problem Solved!! smile

If you get Warning: ini_set() has been disabled for security reason.

You can also refer to:Php ini_set() Warning

 
Magento Community Magento Community
Magento Community
Magento Community
 
rapi77
Jr. Member
 
Total Posts:  3
Joined:  2009-03-22
 

Hi so we just need to ssh in and do the upgrade again and problem solve?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ButterfliesForRelease
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2008-11-16
Brooker, FL
 

If the problem is that you didn’t do a full install (aka, only some packages were upgraded) then it should fix it.

If that isn’t the problem then it will not fix it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rogergerx
Jr. Member
 
Total Posts:  12
Joined:  2009-02-23
 

By Following David help, I did fix the problem. I’m impressed by how fast the system is now. Wow~~

 
Magento Community Magento Community
Magento Community
Magento Community
 
ButterfliesForRelease
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2008-11-16
Brooker, FL
 

It’s annoying, I have 5 sites in production…
I wasn’t planning on upgrading for a while… (to many upgrades resulting in other problems till patched)

Then they come out with a patch like this!
I didn’t get exact numbers, but it does make a huge difference in speed.

I cant wait on the upgrade.
This upgrade is to good smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
AlejandroCCS
Jr. Member
 
Total Posts:  8
Joined:  2009-03-15
 

Hello there guys I’m having the exact same problem after upgrading, I updated all the packages trough Connect; I’m running a test site so I’m not really worried about loosing information but I would like to know other ways to solve this issue with out having to reinstall everything again.

According to you post do I have to necessarily reinstall it again?

 
Magento Community Magento Community
Magento Community
Magento Community
 
rogergerx
Jr. Member
 
Total Posts:  12
Joined:  2009-02-23
 

No. You do not need to reinstall. The problem is when you did the installation, you forgot to add the

--------------------------------------------------
extension key to install:
magento-core/Mage_All_Latest

From David
--------------------------------------------------

I forgot it too. Therefore Some packages were missing.

You have to SSH to your magento server and
do what David mentioned in his post:

./pear install -f magento-core/Mage_All_Latest-stable

That should solve your problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rogergerx
Jr. Member
 
Total Posts:  12
Joined:  2009-02-23
 

No. You do not need to reinstall the whole thing. The problem is when you did the installation, you forgot to add the

--------------------------------------------------
extension key to install:
magento-core/Mage_All_Latest

From David
--------------------------------------------------

I forgot it too. Therefore Some packages were missing.

You have to SSH to your magento server and
do what David mentioned in his post:

./pear install -f magento-core/Mage_All_Latest-stable

That should solve your problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
AlejandroCCS
Jr. Member
 
Total Posts:  8
Joined:  2009-03-15
 

Thank you Guys!

I tried that but I might having issues with my php,ini because I got this message from the ssh shell:

“/home/arbmccs/public_html/magento$ ./pear install magento-core/Mage_All_Latest-stable
-jailshell: line 6: ./pear: Permission denied”

do I have to change the php.ini?

 
Magento Community Magento Community
Magento Community
Magento Community
 
rogergerx
Jr. Member
 
Total Posts:  12
Joined:  2009-02-23
 

Please check out this link

JailShell

I’m on VPS so can’t help you. Sorry ~

 
Magento Community Magento Community
Magento Community
Magento Community
 
AlejandroCCS
Jr. Member
 
Total Posts:  8
Joined:  2009-03-15
 

Thank you, I will verify this with Host Gator I currently have with them a Reseller Account I don’t know if I’m able to run this command.

 
Magento Community Magento Community
Magento Community
Magento Community
 
truckerdeluxe
Jr. Member
 
Avatar
Total Posts:  10
Joined:  2007-08-31
Santa Monica, Ca.
 

I’ve tried to run the command:

./pear install magento-core/Mage_All_Latest-stable

Twice now. The first time I tried it looked like it was downloading several files and installing them. But when I went back to admin and looked in the footer at the version stamp it still says: ver. 1.2.1.2.

I ran the upgrade once more. This time with a different result:

chad-aldersons-macbook-pro-17:truckerdeluxe chadalderson$ ./pear install magento-core/Mage_All_Latest-stable
magento
-core/Lib_Varien requires PHP extension "gd"
magento-core/Lib_Varien requires PHP extension "pdo_mysql"
magento-core/Lib_Varien requires PHP extension "mcrypt"
magento-core/Mage_Core_Modules requires package "magento-core/Lib_Varien" (version >= 1.3.0version <= 1.3.1excluded versions1.3.1)
magento-core/Mage_All_Latest requires package "magento-core/Mage_Core_Modules" (version >= 1.3.0version <= 1.3.0)
magento-core/Mage_Core_Adminhtml requires package "magento-core/Mage_Core_Modules" (version >= 1.3.0version <= 1.3.0)
magento-core/Interface_Adminhtml_Default requires package "magento-core/Mage_Core_Adminhtml" (version >= 1.3.0version <= 1.3.0)
magento-core/Interface_Frontend_Default requires package "magento-core/Mage_Core_Modules" (version >= 1.3.0version <= 1.3.0)
magento-core/Interface_Install_Default requires package "magento-core/Mage_Core_Modules" (version >= 1.3.0version <= 1.3.1excluded versions1.3.1)
No valid packages found
install failed

Any ideas on what is going on?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 6