Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

FATAL ERROR!?!? 
 
leecollings
Jr. Member
 
Total Posts:  16
Joined:  2009-03-17
 

Hello guys, this is my first post as a new Magento user, so far I love it!

But i desperately urgently need some assistance?

After adding products, I keep getting this error message on the product description…

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 491520 bytes) in /home7/partyman/public_html/app/design/frontend/default/eversonstore/template/catalog/product/price.phtml on line 193

Is this a Magento issue, or a database issue?

Please help!!!
lee@lee-collings.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
PaulE
Member
 
Avatar
Total Posts:  43
Joined:  2008-12-09
 
leecollings - 30 March 2009 02:24 AM

Hello guys, this is my first post as a new Magento user, so far I love it!

But i desperately urgently need some assistance?

After adding products, I keep getting this error message on the product description…

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 491520 bytes) in /home7/partyman/public_html/app/design/frontend/default/eversonstore/template/catalog/product/price.phtml on line 193


Is this a Magento issue, or a database issue?

Please help!!!
lee@lee-collings.com

Create an .htaccess file with the following as it’s content:

<IfModule mod_php5.c>
    
php_value memory_limit 128M
</IfModule>
 
Magento Community Magento Community
Magento Community
Magento Community
 
leecollings
Jr. Member
 
Total Posts:  16
Joined:  2009-03-17
 

Hi, thanks for the lightening fast response!

I looked in the .htaccess file, and noticed the limit is already 128, so I thought I’ll whopp it to 1024.

After that, now I get a fatal error message of the folowing:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in /home7/partyman/public_html/lib/Varien/Io/File.php on line 451

and also the product image has now disappeared.

What is actually going on?

If you wish, please take alook for yourself…
http://66.147.242.166/~partyman/index.php/

 
Magento Community Magento Community
Magento Community
Magento Community
 
PaulE
Member
 
Avatar
Total Posts:  43
Joined:  2008-12-09
 

Can you create a file in your root called “test.php” with the following content:

<?php

echo ini_get('memory_limit') . "<br />";

ini_set('memory_limit''256M');
echo 
ini_get('memory_limit');

And can you give me/us the output of this when you go to http://66.147.242.166/~partyman/test.php ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
leecollings
Jr. Member
 
Total Posts:  16
Joined:  2009-03-17
 

32M
256M

 
Magento Community Magento Community
Magento Community
Magento Community
 
PaulE
Member
 
Avatar
Total Posts:  43
Joined:  2008-12-09
 

Ok, so it seems like your host ignores the php_flag in your .htaccess file. What PHP version do you have?

 
Magento Community Magento Community
Magento Community
Magento Community
 
leecollings
Jr. Member
 
Total Posts:  16
Joined:  2009-03-17
 

5.2.9

 
Magento Community Magento Community
Magento Community
Magento Community
 
PaulE
Member
 
Avatar
Total Posts:  43
Joined:  2008-12-09
 

Hmm strange, is there only php_flag which sets your memory_limit in your .htaccess file? If so then you should contact your host about that. It looks like your host doesn’t allow you to use “php_flag” in your .htaccess file

 
Magento Community Magento Community
Magento Community
Magento Community
 
leecollings
Jr. Member
 
Total Posts:  16
Joined:  2009-03-17
 

Hey there,

I’ve just spoken to my host, who gave me some additional help which included instgalling and editing the php.ini file.

All seems to be working fine now!

On visiting your test.php page, I now get

128M
256M

I assume that is what you were expecting? Many thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
PaulE
Member
 
Avatar
Total Posts:  43
Joined:  2008-12-09
 

Yup, thats right smile Glad to help you

 
Magento Community Magento Community
Magento Community
Magento Community
 
FINCHjam
Jr. Member
 
Total Posts:  2
Joined:  2009-04-01
 

PaulE,

Thanks so much for spelling out how to write the test.php file. I’ve been fighting this error for a couple of hours and finally ran across this thread. Your simple instructions certainly helped me out.

Jolene grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
hunnicutt77
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2010-04-20
 

Hey...I had the same problem...made the same changes...but now I have this new error:

---
There has been an error processing your request

Exception printing is disabled by default for security reasons.

Error log record number: 244180583861
---

The strange thing is that I only get this error on the second category on the second subcategory (that make sense?)...it also shows up when I search broad terms like “red”...which multiple products on my site have.

This is just a test store right now, but I would like to figure out how to fix this problem...any help would be greatly appreciated!

http://f2b.buzzhive.net

 
Magento Community Magento Community
Magento Community
Magento Community
 
hasham
Jr. Member
 
Total Posts:  1
Joined:  2010-04-20
 

This topic are depending on the amount of modules you have enabled and their ‘impact’ on the site you may need to increase the memory_limit even more . Image processing often takes a lot of memory, as can working with any large files. Experiment with what memory value works for your needs.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top