Magento Forum

   
bluehost.com error log: missing mcrypt.so ? 
 
trogfish
Member
 
Total Posts:  42
Joined:  2008-12-03
 

My site is up and running, but not yet in production.  I have the same recurring error over and over in my bluehost.com server’s error log. (see below) I simply don’t know what it means or how to fix it.  The only other problem I am aware of is lack of access to my admin-sytem-config-payment webpages; which I am guessing is unrelated?  Therefore, I posted in separate thread:

http://www.magentocommerce.com/boards/viewthread/36864/

Thanks

[10-Mar-2009 13:06:37] PHP Warning:  PHP Startup: Unable to load dynamic library ‘/usr/local/lib/php/extensions/no-debug-zts-20060613/mcrypt.so’ - /usr/local/lib/php/extensions/no-debug-zts-20060613/mcrypt.so: cannot open shared object file: No such file or directory in Unknown on line 0

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1155
Joined:  2008-04-24
 

This means either the mcrypt PHP extension is not properly installed or the path is wrong. mcrypt is one of the system requirements for Magento. You should contact your host as they are the ones who can fix this.

 
Magento Community Magento Community
Magento Community
Magento Community
 
trogfish
Member
 
Total Posts:  42
Joined:  2008-12-03
 
Sindre|ProperHost - 27 March 2009 02:15 AM

This means either the mcrypt PHP extension is not properly installed or the path is wrong. mcrypt is one of the system requirements for Magento. You should contact your host as they are the ones who can fix this.

Yes, thanks.  I reinstalled a new default PHP.INI; and all is well.  I was trying to force the load of mcrypt.so, but that was not nescessary. It was all ready in the default config.

Thanks again.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top