Magento Forum

   
Page 3 of 3
Contact form is not working … but all other emails are ok. 
 
hebert-adias
Jr. Member
 
Total Posts:  1
Joined:  2011-02-08
 

i found the solution in http://inchoo.net/ecommerce/magento/problems-with-contact-form/

...

Change following function of app/code/core/Mage/Core/Model/Email/Template.php (line 585)

public function setReplyTo($email)
  
{
      $this
->getMail()->addHeader(\'Reply-To\'$email);
      return 
$this;
  
}

to

public function setReplyTo($email)
    
{
        $this
->getMail()->setReplyTo($email);
        return 
$this;
    
}

 
Magento Community Magento Community
Magento Community
Magento Community
 
jaywebguy
Jr. Member
 
Total Posts:  26
Joined:  2010-09-01
 

I had the same problem. Turns out the issue had to do with my server. If I tried to send the email to a local address they would fail. So I fixed the code as indicated in the previous post, then I sent up a temporary gmail account to send the email to. Within the gmail account I created a forwarding rule to forward them on to the local email address, now it all works. Also check your junk folders, mine were getting flagged as spam.

Jason

 
Magento Community Magento Community
Magento Community
Magento Community
 
marchman
Jr. Member
 
Total Posts:  12
Joined:  2010-09-20
 

Just a quick note. I was having problems with sending from the contact form until I realized the to and from email addresses were the same.

Some servers will reject emails where the “to” and “from” address is the same because it will classify it as spam. My emails were not getting through until I changed the from address in the configuration > contacts > email options.

May explain why some of the emails get through and others don’t.

 
Magento Community Magento Community
Magento Community
Magento Community
 
albertramsbottom
Sr. Member
 
Total Posts:  77
Joined:  2010-12-20
 

I have tried everything in this email thread and nothing seems to work, my contact form is busted

:(

 
Magento Community Magento Community
Magento Community
Magento Community
 
FntsyBlacksmith
Jr. Member
 
Avatar
Total Posts:  21
Joined:  2009-09-28
 
hebert-adias - 09 February 2011 04:37 AM

i found the solution in http://inchoo.net/ecommerce/magento/problems-with-contact-form/



Change following function of app/code/core/Mage/Core/Model/Email/Template.php (line 585)


public function setReplyTo($email)
  
{
      $this
->getMail()->addHeader(\'Reply-To\'$email);
      return 
$this;
  
}

to

public function setReplyTo($email)
    
{
        $this
->getMail()->setReplyTo($email);
        return 
$this;
    
}

This did it for me! May Ala rain down blessings upon your grandchildren!

 
Magento Community Magento Community
Magento Community
Magento Community
 
chloeottawa
Jr. Member
 
Total Posts:  1
Joined:  2011-06-29
 

Hello,

My contact form is not working. I am new to Magento. I had someone build the site but found out the form is not working.

My version is Magento ver. 1.4.1.1

when I view source the post is

<form action="http://pureoriginshair.com/contacts/index/post/" id="contactForm" method="post">
after I submit the form in the url it shows

http://pureoriginshair.com/contacts/index/

I do get a message “Your inquiry was submitted and will be responded to as soon as possible. Thank you for contacting us.”

when I go into the Admin Panel / Configuration > Contacts
the Enable Contact us is - Yes
email option has my email
email sender is set to custom email 2
enable template is set to contact form (default template from Locale)

any assistance would be great!

 
Magento Community Magento Community
Magento Community
Magento Community
 
HectorPN
Member
 
Total Posts:  74
Joined:  2010-03-21
Adelaide, Australia
 
robyng - 28 May 2009 03:43 AM

I also had the same problem .  Emails were sent when I used the Contact Us form in the footer but not when it was included within a cms page.  My solution was as follows:  Call the form from the cms page as follows:

<!– CONTACT FORM –>
{{block type=’core/template’ name=’contactForm’ template=’contacts/form.phtml’}}
<!– END OF CONTACT FORM –>
Note the use of single inverted commas when calling the form in the block. I could not get it to show at all with double inverted commas.

Find /contacts/form.phtml in your theme directory and change

<form action="<?php echo $this->getFormAction(); ?>” id="contactForm" method="post">

To

<form action="http://www.yourdomainname.com/contacts/index/post/" id="contactForm" method="post">


Worked for me.

This is an old thread but just worked for me so here are my 2 cents:

Instead of hard coding the domain, in case you are in multi store, just leave it las a relative path ike this:

<form action="/contacts/index/post/" id="contactForm" method="post">

 
Magento Community Magento Community
Magento Community
Magento Community
 
fintan74
Jr. Member
 
Total Posts:  14
Joined:  2012-03-04
 
marchman - 13 April 2011 01:00 PM

Just a quick note. I was having problems with sending from the contact form until I realized the to and from email addresses were the same.

Some servers will reject emails where the “to” and “from” address is the same because it will classify it as spam. My emails were not getting through until I changed the from address in the configuration > contacts > email options.

May explain why some of the emails get through and others don’t.

Thanks; this worked for me too. Could not receive e-mails, but changing the receiver solved the problem

 
Magento Community Magento Community
Magento Community
Magento Community
 
payair
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2012-12-04
Hollywood, FL
 

Thanks catoctin, your suggestion worked for my setup.  We are using Nexcess for hosting and using Google Apps for our mail server so disabling the local delivery service allowed emails generated from the Magento contact form to be delivered to our email address with the same domain.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 3 of 3