Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Search not working - Returning no results
 
Rob22193
Jr. Member
 
Total Posts:  26
Joined:  2008-11-14
 

Hello community -

My search function returns no results.  It had worked in the past so I’m not sure at what point it stopped working.  I am currently on version 1.2.1.2 and not sure if upgrading to this version had anything to do with it.

Secondly, if I search for something and get the no results message and try to enter another search term, my site just hangs up after trying to search for something the second time.

Anyone else experiencing similar problems or have any suggestions.

Thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiaraweb
Guru
 
Avatar
Total Posts:  721
Joined:  2008-03-21
Aviano ~ Italy
 

go to admin -> system -> cache management -> rebuild SEARCH INDEX

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rob22193
Jr. Member
 
Total Posts:  26
Joined:  2008-11-14
 

I do not see anything relating to “rebuild search index” under System->Cache Management

I am on Version 1.2.1.2.  Was this something found on older version?

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
royalije
Member
 
Total Posts:  37
Joined:  2008-05-29
Spain
 

That option she mentioned is actually found on version 1.2.1.2 - are you sure you’re runing version 1.2? - that’s the correct way to solve the issue…

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Moderator
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

1.2.1.2 has the Search Index rebuild near the bottom of the Cache Management page (Admin -> System -> Cache Management)

If you are not seeing it then try deleting the contents of your magento/var/cache folder as well as your browser cache. Close and reopen your browser.

Image Attachments
1.2.1.2.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Rob22193
Jr. Member
 
Total Posts:  26
Joined:  2008-11-14
 

I figured it out.  I’m not sure why the “Search Index” rebuild was not showing in Cache Management, however, I found another post that said to install the “magento-core/Mage_All_Latest” extension through Magento Connect.

After I installed that, the Search Index button showed up and my search problem was fixed.  Thanks to all that responded.

 
Magento Community Magento Community
Magento Community
Magento Community
 
caterox
Jr. Member
 
Total Posts:  11
Joined:  2009-01-08
 

thank you man, I soooo needed this smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top