Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Configurable attributes not in layered navigation
 
terici
Jr. Member
 
Total Posts:  13
Joined:  2008-09-22
 

Hi evrybody,

I got a problem since two days, and I cant fixed it. Please help me !

I imported products with a custom script to import configurable products. Everything is fine, in that point, but I can’t see the attributes in the layered navigation, so I try to refresh it in the cache managment, still no result in my layered navigation. I had a look in ‘catalogindex_eav’, and I can see that my attributes are not inside, so it’s normal that they didn’t appear in my navigation.

So, I try to make the same configurable and simple products by hand in the admin, and that’s work, I can see my attributes in the layered navigation. So it’s look like that I miss something in my import script. After looking in all the database, all the tables concerning the products, I can’t see what I’m missing. After some test, I can say that the problem come from the simple product, because when I edit the imported configurable product and I associate simple products (made by hand in admin), everything is fine, and my attributes are in layered navigation. Only the association with my imported simple product, doesn’t display the attribute in my layered navigation (I mean my problem is only layered navigation attribute).

If I had the good informations, in catalogindex_eav, of course it’s working. But when I refresh the layered navigation they have been deleted from catalogindex_eav.

I’m still looking for a solution !!!

Please, do you have any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top