Magento Forum

   
Page 1 of 3
Forum Posting replies slow
 
brendanb
Mentor
 
Total Posts:  1077
Joined:  2008-07-16
London, United Kingdom
 

im not sure if its just me, but when i try and post a reply to a question in the forums its taking up 15 secs to post.

i have tested my connection and im currently getting 9mb down 1 mb up
im based in the UK.

this doesnt seem ideal

 
Magento Community Magento Community
Magento Community
Magento Community
 
brendanb
Mentor
 
Total Posts:  1077
Joined:  2008-07-16
London, United Kingdom
 

actually just posting the above topis took 50secs to post.

what is going on with this forum?

 
Magento Community Magento Community
Magento Community
Magento Community
 
J_T_
Mentor
 
Avatar
Total Posts:  1961
Joined:  2008-08-07
London-ish, UK
 

It’s been dead slow for me to load/post from the UK for months. Loading this page took 50.16 seconds according to YSlow. I started a thread and Roy Rubin said they’d monitor it. It’s frustrating me so much, I’m probably posting 10% of what I would have posted in the forum and bug reports.

(Bracing myself for submitting this post, time for a cuppa)

 
Magento Community Magento Community
Magento Community
Magento Community
 
J_T_
Mentor
 
Avatar
Total Posts:  1961
Joined:  2008-08-07
London-ish, UK
 

Posting and subsequent loading of this page took 63.279 seconds…

 
Magento Community Magento Community
Magento Community
Magento Community
 
brendanb
Mentor
 
Total Posts:  1077
Joined:  2008-07-16
London, United Kingdom
 

hey JT,

ah good so its just not me grin going a little crazy.
something is very wrong here…

 
Magento Community Magento Community
Magento Community
Magento Community
 
brendanb
Mentor
 
Total Posts:  1077
Joined:  2008-07-16
London, United Kingdom
 

that last post took 16secs.
better but still no where near acceptable

 
Magento Community Magento Community
Magento Community
Magento Community
 
brendanb
Mentor
 
Total Posts:  1077
Joined:  2008-07-16
London, United Kingdom
 

hmmm,

im going to keep banging on about this.

still too slow. i post here pretty often and its by far the slowest forum ive ever used.

brendan

 
Magento Community Magento Community
Magento Community
Magento Community
 
Stuarts
Member
 
Total Posts:  66
Joined:  2009-03-16
 

100% Agree.

This is an incredibly slow forum.

In fact, lets be honest, the whole of the http://www.magentocommerce.com site is quite slow and painful to use.

To load this page to post this just took 20 seconds.

That is a joke.

Guys - You don’t seem to realise that people judge Magento on factors like the page load of the magentocommerce.com site BEFORE they ever download the software.

The psychology is simple. If they cannot make their own site fast, then how quick is the shopping cart likely to be?

This definitely costs you downloads. No doubt about it.

Fair or not, thats the truth.

Compare this forum to Wordpress.orgs, which undoubtedly gets more traffic (it has an alexa ranking 339, compared to 4231 for magentocommerce.com), but is still miles faster.

You need to hire some guru server guys and get them to figure out how to speed this thing up, because currently it is a painful, painful experience to use this site.

EDIT - It took 55.251 seconds as measured by yslow to post the above post

 
Magento Community Magento Community
Magento Community
Magento Community
 
J_T_
Mentor
 
Avatar
Total Posts:  1961
Joined:  2008-08-07
London-ish, UK
 

16.5 seconds to load this post… It’s taken 46s to actually post this reply. It took 9.2s to open this “edit post” screen and I’m sure another 30 odd seconds to post this edit.

I also get frequent time-outs on replies, ending in a white screen.

 
Magento Community Magento Community
Magento Community
Magento Community
 
brendanb
Mentor
 
Total Posts:  1077
Joined:  2008-07-16
London, United Kingdom
 

nice one,

thanks for chipping in. I thought it was something to do with my ISP or some funny dns issues.

hope they pick this one up and move on it quicky

brendan

PS. that post took well over 1 min to post. Thats pretty bad

 
Magento Community Magento Community
Magento Community
Magento Community
 
Stuarts
Member
 
Total Posts:  66
Joined:  2009-03-16
 

I literally just went and made a cup of tea when starting up this forum.

84.52 seconds on yslow upon my return to find a white screen and another refresh needed. (And I have a superfast 20MB Cable Connection)

Hmmm.... Three people have now posted in this thread. I see a trend…

I wonder if the Magento forum is really a ‘Classic Emulator’ (like you see sometimes for Pac Man) to remind us all of what surfing the web on a 28k Modem was like grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
Stuarts
Member
 
Total Posts:  66
Joined:  2009-03-16
 

96.455 seconds to post the above…

 
Magento Community Magento Community
Magento Community
Magento Community
 
brendanb
Mentor
 
Total Posts:  1077
Joined:  2008-07-16
London, United Kingdom
 

good stuff,

yeah i noticed that there are a few duplicate & triplicate posts in the forums.
The page not found issue would explain why there are duplicate/triplicate posts. As i user you dont know what happened, hence you “backpage” and re-post!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Stuarts
Member
 
Total Posts:  66
Joined:  2009-03-16
 

Brendan, J.T and Me all reside in the UK so clearly there is a problem there.

I would have thought the obvious answer would be to mirror the servers to a host in the UK so that folk on this side of the pond start getting load times that are not in the realms of fantasy. (90 seconds to post is crazy)

Calling someone in to investigate is obviously a must, as we can’t all be imagining that using this forum is like pulling teeth.

It is interesting that you are in the States and still getting slow, unresponsive interaction with this site.

That tends to indicate that something more radical, like a re-write of the forum software (or change to a faster one) is called for.

Either way, its not rocket science. There must be server guys who specialise in high load websites and can tweak a few things to get it moving.

It is hard to communicate effectively, when you grow a mustache in between posting grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
Stuarts
Member
 
Total Posts:  66
Joined:  2009-03-16
 

Yslow lives here

http://developer.yahoo.com/yslow/

If you are reading this, then feel free to download yslow (its a free add-on for firefox) and post how long it takes you to post to this forum.

The more the merrier grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
J_T_
Mentor
 
Avatar
Total Posts:  1961
Joined:  2008-08-07
London-ish, UK
 

(Loading this page: 19.7 seconds)

I hope I don’t get banned for a DOS attack but I just ran an ab test on this thread from a test box here in the office to see what happens:

# ab -n 100 -c 5 http://www.magentocommerce.com/boards/viewthread/36205/P0/

Benchmarking http://www.magentocommerce.com (be patient)...apr_recv: Connection reset by peer (104)
Total of 71 requests completed

It doesn’t even complete… Let’s lighten the load to just one user hammering 10 requests:

# ab -n 10 -c 1 http://www.magentocommerce.com/boards/viewthread/36205/P0/

Server Software:  Apache/2.0.63
Server Hostname:  http://www.magentocommerce.com
Server Port:  80

Document Path:  /boards/viewthread/36205/P0/
Document Length:  92390 bytes

Concurrency Level:  1
Time taken for tests:  45.671818 seconds
Complete requests:  10
Failed requests:  0
Write errors:  0
Total transferred:  934010 bytes
HTML transferred:  923900 bytes
Requests per second:  0.22 [#/sec] (mean)
Time per request:  4567.182 [ms] (mean)
Time per request:  4567.182 [ms] (mean, across all concurrent requests)
Transfer rate:  19.97 [Kbytes/sec] received

Connection Times (ms)
min mean[+/-sd] median max
Connect:  125 127 1.9 127 131
Processing:  2641 4438 1891.1 3794 8261
Waiting:  1963 3739 1896.9 3107 7577
Total:  2770 4566 1890.3 3920 8386

Percentage of the requests served within a certain time (ms)
50% 3920
66% 4184
75% 4676
80% 7588
90% 8386
95% 8386
98% 8386
99% 8386
100% 8386 (longest request)

Yes, that’s a whopping 0.22 requests per second and not even 20Kb / sec transfer. That’s on an 8 Meg ADSL line with low contention ratio.

Hope this helps whoever may look into this for us poor UK based sufferers! This abuse has got to stop! We are being discriminated against smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 1 of 3