Magento Forum

   
Page 5 of 5
Internal server error (500) - please help …
 
BarryS2
Jr. Member
 
Total Posts:  1
Joined:  2012-06-30
 
floydfarms - 30 July 2011 08:15 AM

Options +FollowSymLinks

This line in the ,htaccess file is causing the 500 Internal Server Error for me. I simply comment it out and magic!

This one worked for me… thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
fisherguy
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2012-06-06
 
Moshe - 18 February 2008 10:29 AM

Please set permission 755 for magento folder and index.php

Thank you very much! I have been stuck in this problem for several hours, finally your advice soloved my problem. I would recommend this tips to other people. I am using godaddy virtual dedicated server, and cPanel. magento 1.7.0.2.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rastgoo
Member
 
Avatar
Total Posts:  49
Joined:  2009-04-03
Ottawa, ON
 

I just deleted the htaccess file.

now its working

 
Magento Community Magento Community
Magento Community
Magento Community
 
blackfrost79
Jr. Member
 
Total Posts:  1
Joined:  2012-11-02
 
Rastgoo - 31 July 2012 07:47 AM

I just deleted the htaccess file.

now its working

Same here. After trying all the previous suggestions, deleting htaccess fixed it for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Marko L
Jr. Member
 
Total Posts:  3
Joined:  2010-03-18
 

Have anybody solution for this problem:
Fatal error: Call to a member function getIdFieldName() on a non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Abstract.php on line 151

On fresh installed magento 1.7.0.2, I have error 500. When I check description of error in apache log I see that message:
Fatal error: Call to a member function getIdFieldName() on a non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Abstract.php on line 151

 
Magento Community Magento Community
Magento Community
Magento Community
 
carlosesierra
Jr. Member
 
Total Posts:  7
Joined:  2013-01-16
 

I had two days with this problem:

Moshe: Marry me!!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
jonas1045
Jr. Member
 
Total Posts:  1
Joined:  2012-11-14
 

If you are getting page 500 and this error:
[Mon May 27 19:19:16 2013] [error] [client IPHERE] SoftException in Application.cpp:422: Mismatch between target UID (500) and UID (1072) of file “/home/MY_WEBSITE/public_html/index.php”

Then the solution is changing from suPHP to cgi..
Go to WHM: Service Configuration -> Configure PHP and suEXEC: Change suPHP to cgi, and enable suEXEC, just run and the problem is solved. Hope is can help some people out there smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
jicksonkoottala
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2012-03-06
Aluva
 

I think it is because of the incorrect file permission

use the below details

find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;
chmod o+w var/.htaccess
chmod 550 mage

chmod -R o+w media var
chmod o+w app/etc

If the above not works Replace the “.htaccess” file in the root folder with a new one from a fresh magento installation ( based on your magento version )

I hope this will help smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Skorpion_CC
Jr. Member
 
Total Posts:  1
Joined:  2013-09-01
 
phaamai - 24 May 2011 08:41 PM

alfin - 22 November 2008 04:34 AM
megento 1.1.6 : rename the .htaccess anything what u like, such as;

$ mv .htaccess .htaccess-bak

this means skip this file. This work to me and run well

-alfin-

Worked for me with 1.5. Thanks.

Hello, this works for me.
I have also change permissions for 755 and work as well.
Many thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
yuriymos
Jr. Member
 
Total Posts:  11
Joined:  2013-11-18
 
Frawanaz - 18 February 2008 10:45 AM

Moshe - 18 February 2008 10:29 AM
Please set permission 755 for magento folder and index.php

Worked after changing permission to 775

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jase007
Guru
 
Total Posts:  388
Joined:  2013-11-05
 

Hi,

You can set permission 755 for magento folder and index.php

Thanks

iLoveMage

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 5 of 5