Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Internal server error (500) - please help …
 
Paulus
Guru
 
Total Posts:  335
Joined:  2008-07-21
 

Out of the blue, all we get are error 500 messages on all of our categories, exept one from the 1500+.

The one that does work is exactly setup the same as the others.

We spend 30 hours, with three tech guys on thuis issue and nothing worked. Even overwriting the dbase with a new install (old dbase) did not work, still error 500 on all category pages.

Before it worked flawlessly for at least the past 12 months:/

Any tips left?

 
Magento Community Magento Community
Magento Community
Magento Community
 
sourav the inventer
Jr. Member
 
Avatar
Total Posts:  27
Joined:  2010-06-11
India, Westbengal, Kolkata
 

I have found a simple solution
go to your magento root directory
make it permission 755
and index.php in the root make it permission 755

magento will install easily

now if u get problem in magento connect then fo to the downloads folder
make it permission 755
and index.php which have in downloads folder make it permission 755.

your magento connect run fine…
have fun....

 
Magento Community Magento Community
Magento Community
Magento Community
 
seanbreeden
Member
 
Avatar
Total Posts:  74
Joined:  2010-02-12
Cincinnati, OH
 

You should also check your file ownership.  Make sure the file owners are all set correctly.  Do a “ll” or “ls -l” to see what your public_html, httpdocs or html folders owner and group is set to.  If you’re in plesk the files and folders should all be set to your ftp name and psacln for the group.  All other will probably be apache:apache or ftp name:group name, just check the other siblings to your web root.

-Sean

 
Magento Community Magento Community
Magento Community
Magento Community
 
digikaye
Jr. Member
 
Total Posts:  1
Joined:  2011-07-24
 

To Moshe and Frawanaz - I just want to say thank you, thank you, thank you!  I spent hours trying to sort things out before I found this advice and it finally worked perfectly!

 
Magento Community Magento Community
Magento Community
Magento Community
 
plpaquin
Jr. Member
 
Total Posts:  1
Joined:  2011-07-25
 

Hi,

I have the same problem with a 500 internal server Error

This is my log on my cpanel:

[Mon Jul 25 21:46:22 2011] [error] [client 70.80.179.95] File does not exist: /home/thebens/public_html/404.shtml
[Mon Jul 25 21:46:22 2011] [error] [client 70.80.179.95] File does not exist: /home/thebens/public_html/favicon.ico
[Mon Jul 25 21:46:22 2011] [error] [client 70.80.179.95] File does not exist: /home/thebens/public_html/500.shtml
[Mon Jul 25 21:46:22 2011] [alert] [client 70.80.179.95] /home/thebens/public_html/magento/.htaccess: Invalid command ‘php_flag’, perhaps misspelled or defined by a module not included in the server configuration

Here my .htaccess

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

Action php5-cgi /cgi-bin/php5-cgi
AddHandler php5-cgi .php
php_flag cgi.fix_pathinfo on

############################################
## GoDaddy specific options

# Options -MultiViews

## you might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## if it still doesn’t work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

# php_value memory_limit 64M
php_value memory_limit 256M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter on all content
###SetOutputFilter DEFLATE
# Insert filter on selected content types only
#AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault “access plus 1 year”

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

###########################################
## Deny access to release notes to prevent disclosure of the installed Magento version

<Files RELEASE_NOTES.txt>
order allow,deny
deny from all
</Files>

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

Someone can help me please?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
floydfarms
Jr. Member
 
Total Posts:  1
Joined:  2011-07-30
 

Options +FollowSymLinks

This line in the ,htaccess file is causing the 500 Internal Server Error for me. I simply comment it out and magic!

 
Magento Community Magento Community
Magento Community
Magento Community
 
suleymankaygisiz
Member
 
Total Posts:  55
Joined:  2010-06-30
 

Hi all,
I also had this 500 error when moved to an other vps.

My sollution was playing around with the query cache stuff in /etc/mysql/my.cnf and the memory limit in .htacces

Btw I thought that that 500 was only for permission or bad linking errors. What does this has to do with the sql query cache memmory?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ashishkhadpe
Member
 
Total Posts:  58
Joined:  2011-08-22
 

This problem generally occurs when we don’t have correct permission on files during installation Magento Expects that Each and Every folder and File with permissions 755. So to avoid this problem you need to change permission of Magento Folder and index.php to 755. Sometimes it is also required to change the permission of .htaccess to 755.
Blog Link : Magento Coders

 
Magento Community Magento Community
Magento Community
Magento Community
 
akfciw
Jr. Member
 
Total Posts:  5
Joined:  2011-11-01
 

OK Finally smile))

Perrmissions : Folders : 755 , All PHP Files 755 ( index.php , install.php , cron.php , get.php )
Deleted .htacsses and .htacsses.sample ( both of them ) and new clear one with 644 permission
and also magento folder 755

Then Finish :D

 
Magento Community Magento Community
Magento Community
Magento Community
 
vjtemplates
Guru
 
Avatar
Total Posts:  408
Joined:  2010-12-15
Washington, USA
 

By default 755 for folders and 644 for files are enough. Don’t go beyond that. 500 Internal Server error usually related to server or htaccess issue. Check your htaccess or consult your host for solution.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MrPhpGueu
Jr. Member
 
Total Posts:  1
Joined:  2009-02-27
 

Thanks man i got the solution and i solve my prob at my store

 
Magento Community Magento Community
Magento Community
Magento Community
 
dave_dhaval
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2012-05-18
 

Down load “Magento Cleanup Tool” zip. and run magento-cleanup.php file from that zip like http://yourdomain.com/magento/magento-cleanup.php. but please delete content from .htacess befor run this file..

this file set permission for directory and files for magento.. I have used it and its working fine for me..

You can download this file from ..
http://www.learnmagento.org/magento-bug-fixes/solve-500-internal-server-error-on-magento-installation/comment-page-1

Thanks,
dhaval

 
Magento Community Magento Community
Magento Community
Magento Community
 
sujansakya
Jr. Member
 
Total Posts:  1
Joined:  2012-05-22
 

replaced FollowSymLinks with SymLinksIfOwnerMatch in .htacess worked for me

 
Magento Community Magento Community
Magento Community
Magento Community
 
Pino1987
Jr. Member
 
Total Posts:  25
Joined:  2012-06-11
 

hi,
i have upload directory magento into to my site http://www.topofminditalia.it/magento.
i have setting permission 775 on the directory but i have still a message error:
Notice: Trying to get property of non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Config.php on line 1227

Notice: Trying to get property of non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Config.php on line 1227

Notice: Trying to get property of non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Config.php on line 1227

Notice: Trying to get property of non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Config.php on line 1239

Fatal error: Call to a member function getIdFieldName() on a non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Abstract.php on line 151

how can i do?

thanks for support

 
Magento Community Magento Community
Magento Community
Magento Community
 
Pino1987
Jr. Member
 
Total Posts:  25
Joined:  2012-06-11
 

hi,
i have upload directory magento into to my site http://www.topofminditalia.it/magento.
i have setting permission 775 on the directory but i have still a message error:
Notice: Trying to get property of non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Config.php on line 1227

Notice: Trying to get property of non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Config.php on line 1227

Notice: Trying to get property of non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Config.php on line 1227

Notice: Trying to get property of non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Config.php on line 1239

Fatal error: Call to a member function getIdFieldName() on a non-object in /homez.520/topofmin/www/Magento/app/code/core/Mage/Core/Model/Abstract.php on line 151

how can i do?

thanks for support[size=1]

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top