Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Internal server error (500) - please help …
 
Prodigy
Jr. Member
 
Total Posts:  9
Joined:  2009-10-13
 

I’am also getting same error.
Here’s the Error Log..

[Sat Oct 31 16:16:26 2009] [error] [client 122.163.XXX.XX] File does not exist: /home/xxxx/public_html/404.shtml
[Sat Oct 31 16:16:26 2009] [error] [client 122.163.XXX.XX] File does not exist: /home/xxxx/public_html/favicon.ico
[Sat Oct 31 16:16:24 2009] [error] [client 122.163.XXX.XX] File does not exist: /home/xxxx/public_html/500.shtml
[Sat Oct 31 16:16:24 2009] [error] [client 122.163.XXX.XX] SoftException in Application.cpp:256: File “/home/xxxx/public_html/store/index.php” is writeable by group.

I’am sure i’ve set the permissions right, but don’t know why it’s still happening.

Any clues?

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Joel Green
Jr. Member
 
Total Posts:  8
Joined:  2008-10-31
 

SAME “500 Internal Server Error” as above....

[Sat Oct 31 13:57:49 2009] [error] [client 74.243.225.90] File does not exist: /home/myfloors/public_html/500.shtml
[Sat Oct 31 13:57:48 2009] [error] [client 74.243.225.90] File does not exist: /home/myfloors/public_html/500.shtml
[Sat Oct 31 13:57:47 2009] [error] [client 74.243.225.90] File does not exist: /home/myfloors/public_html/404.shtml
[Sat Oct 31 13:57:47 2009] [error] [client 74.243.225.90] File does not exist: /home/myfloors/public_html/favicon.ico
[Sat Oct 31 13:53:08 2009] [error] [client 74.243.225.90] File does not exist: /home/myfloors/public_html/500.shtml

What is the deal here?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Joel Green
Jr. Member
 
Total Posts:  8
Joined:  2008-10-31
 

Prodigy, just fixed our issues with some trial and error but it all comes down to file and directory permissions

I went into my FTP and highlighted every file under my /store/ file and set the permissions to 644

THEN i selected every FOLDER under my /store/ area to 755

worked perfectly after that

and I do have PHP5 and SuPHP enabled

 
Magento Community Magento Community
Magento Community
Magento Community
 
benblee
Jr. Member
 
Total Posts:  13
Joined:  2009-01-15
 

Hey Prodigy, you said you are sure you’ve set the permissions right but the error message you posted says you’ve set them wrong.  It says that your config file is “group writable”.  Most hosting set ups won’t let you have “group writable” files or folders.  Change files to 644.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jfares
Jr. Member
 
Total Posts:  1
Joined:  2009-07-06
 

644 for index.php worked for me too.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Goysar
Jr. Member
 
Total Posts:  3
Joined:  2010-01-02
 

Changing the permissions of the app,media,var folder to 777 or 755 will work.

Its solved my problem

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tuppi Sau
Member
 
Total Posts:  34
Joined:  2010-01-18
 

Guys, the online installation for Magento has too many of the bugs, so don’t try to online install the magento, use the offline installer instead. Just go to Download section for magento and download the full package. Delete all the files from your server and upload the full installation package. Then the installation is a piece of cake. Otherwise you will be ending up in changing the permission for all the folders, subfolders and the files.

Hope this helps. smile Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
lazytrbar
Jr. Member
 
Total Posts:  13
Joined:  2010-02-25
 

I was getting an internal error 500 when trying to use the admin panel right after install.  The frontend would work, but the backend would not.  I checked file permissions as described in this post and they were already set that way.  I contacted tech support of my host (ixwebhosting) and after looking at my logs they increased the PHP memory related to my domain and that seemed to fix the problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lividinstruments
Member
 
Total Posts:  64
Joined:  2008-10-03
 

I have been trying and trying for days here. I am not sure what I am doing wrong. I did install it once, but not with the correct database. When I did I get the internal server error. I have corrected permissions, and changed everything the damn thing just wont work for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
derkomtur
Jr. Member
 
Total Posts:  1
Joined:  2010-12-23
 

Hi,

I tried to all the above mentioned, but nothing helped. Still error 500.

My hoster gave me the hint to change the following in the .htaccess:

Change:

Options +FollowSymLinks

to:

Options +SymLinksIfOwnerMatch

Now it works for me, I hope this will break nothing within Magento. wink

Maybe this little hint is usefull for someone else.

--
Cheers,
-René

 
Magento Community Magento Community
Magento Community
Magento Community
 
rusty1001
Jr. Member
 
Total Posts:  14
Joined:  2008-10-28
 
Moshe - 18 February 2008 10:29 AM

Please set permission 755 for magento folder and index.php

THANK YOU - THAT WORKED FOR ME!

 
Magento Community Magento Community
Magento Community
Magento Community
 
degen
Jr. Member
 
Total Posts:  1
Joined:  2011-03-01
 

The \’755 for directory and 644 for index.php\’ worked for my internal server error as well.

Thnx all,

Alex

 
Magento Community Magento Community
Magento Community
Magento Community
 
phaamai
Jr. Member
 
Total Posts:  1
Joined:  2011-05-16
 
alfin - 22 November 2008 04:34 AM

megento 1.1.6 : rename the .htaccess anything what u like, such as;

$ mv .htaccess .htaccess-bak

this means skip this file. This work to me and run well

-alfin-

Worked for me with 1.5. Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
NeilMeister
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2011-05-27
 
derkomtur - 23 December 2010 04:29 AM

Hi,

I tried to all the above mentioned, but nothing helped. Still error 500.

My hoster gave me the hint to change the following in the .htaccess:

Change:

Options +FollowSymLinks

to:

Options +SymLinksIfOwnerMatch


Now it works for me, I hope this will break nothing within Magento. ;)

Maybe this little hint is usefull for someone else.

--
Cheers,
-René

For me, a similar tweak worked.  I don’t know where I found the help, but somewhere in the forum here someone mentioned their server logs specifying there was a problem with “Options +FollowSymLinks”.  I commented this out of the .htaccess in my main installation directory, and zippity-do-da, the install ran through like a champ.

Furthermore, (having installed the sample data) when I browsed the store, product images weren’t showing up.  I navigated to the image URLs and got Internal Server Error messages as well.  Commenting out ALL of the “Options” lines in media/.htaccess ("#Options All -Indexes”, “#Options -ExecCGI”, “#Options +FollowSymLinks") solved this problem.

Hope this helps someone… I spun my wheels for the better part of a day looking for a solution.

 
Magento Community Magento Community
Magento Community
Magento Community
 
rhanz
Jr. Member
 
Total Posts:  3
Joined:  2011-06-01
 

i tried all the procedures from above
still no luck :(

still having 500 internal error

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top