Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Missing image icon in Safari and Chrome
 
stanb17
Member
 
Total Posts:  34
Joined:  2010-06-02
 

Both Chrome and Safari display a missing image icon above the right column Paypal link.

https://www.discountguitarparts.com

The icon is looking for “something” in the https://www.discountguitarparts.com/skin/frontend/default/ma_carstore/
directory. It does not specify what resource it is looking for. The directory does exist.

How can I kill and/or activate this icon.
Note: Does not show in MSIE or FF.

Almost there with this one.
Thanks for any help. Great appreciated, as always.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kdigennaro
Member
 
Total Posts:  47
Joined:  2012-05-20
 

Hey there,
Hopefully I can help shed some light on this problem. After inspecting the area you are having problems with I found that it is looking for the image for that icon in the directory https://www.discountguitarparts.com/skin/frontend/default/ma_carstore/ which is inside of ‘block content’. Have you looked at the backend of the side? Under CMS-->Pages-->Home-->Content check to see if it is calling any images that you have not put on your site. It could be left over from the default banner. Firefox does read that image it is just not displaying it because it doesn’t exist. Safari and chrome display an error message instead (that icon you are seeing). Hopefully this helps some if not maybe copy and paste the information under ‘content’ in the backend and I will take a look.

Best Regards,
Kevin DiGennaro

 
Magento Community Magento Community
Magento Community
Magento Community
 
stanb17
Member
 
Total Posts:  34
Joined:  2010-06-02
 

Thanks Kevin.
Looking into CMS - Pages - Home I see this which came via the ma_store theme template install guide (I think).

{{block type="featuredproductslider/featuredproductslider" name="featuredproductslider" template="magentothem/featuredproductslider/featuredproductslider.phtml"}}{{block type="newproduct/newproduct" name="newproduct" template="magentothem/newproduct/newproduct.phtml"}}

That said… I don’t think “featuredproductslider” has anything to do with it. I also just looked into “newproduct” and that block is working fine.

Obviously what is frustrating is the culprit is not revealed in the string. If it were, I’d have an easier time troubleshooting this bugger.

Still on the hunt.....

 
Magento Community Magento Community
Magento Community
Magento Community
 
kdigennaro
Member
 
Total Posts:  47
Joined:  2012-05-20
 

Have you tried removing the image slider block and seeing what happens? Just cut it and save and see what happens. If that doesn’t fix it or if it removes you’re image slider then just put it back.

Also have you turned template path hints on in the back end? That will show you were it is coming from and you should be able to debug pretty quickly. Simply go to system-->config-->developer (on the left hand side). Make sure you select your store from the default store to whatever store you are using. It most likely will be ‘main store’. Turn template path hints on and it will tell you what template path that is hiding in.

Hope that helps,
Kevin DiGennaro

 
Magento Community Magento Community
Magento Community
Magento Community
 
stanb17
Member
 
Total Posts:  34
Joined:  2010-06-02
 

Okay Kevin… getting down to the nitty and gritty,

Template Hints revealed 3 paths

frontend/default/ma_carstore/template/magentothem/bestsellerproductvertscroller/bestsellerright.phtml

frontend/default/ma_carstore/template/magentothem/right_static.phtml

frontend/base/default/template/callouts/right_col.phtml

With a significant caffeine deficiency as my first excuse, I am at a lack of a solution. Should I search and destroy (comment out) any lines referring to these phtml files or is there a less invasive surgery I can perform?

Your willingness to help and patience is commendable.

Thanks

Stan

Addendum: I have since “Enabled” the “bestsellerproductscroller” in the theme config. So that works… but did not get rid of error. So.. I then went to “right_static.phtml” and “Enabkled it” and also commented out the following…

<!-- <p><img src="{{media url="wysiwyg/Right_Static.png"}}" alt="” /></p>
<p><a href="#"><img src="{{media url="wysiwyg/right.png"}}" alt="” /></a></p> -->

Still shows error.  Lastly I looked at the frontend/base/default/template/callouts/right_col.phtm
which contains the following code, which I promptly discovered I know not what to do with....

<div class="block block-banner">
<div class="block-content">
<?php if(strtolower(substr($this->getLinkUrl(),0,4))==='http'): ?>
<a href="<?php echo $this->getLinkUrl() ?>” title="<?php echo $this->__($this->getImgAlt()) ?>">
<?php elseif($this->getLinkUrl()): ?>
<a href="<?php echo $this->getUrl($this->getLinkUrl()) ?>” title="<?php echo $this->__($this->getImgAlt()) ?>">
<?php endif; ?>
<img src="<?php echo $this->getSkinUrl($this->getImgSrc()) ?>"<?php if(!$this->getLinkUrl()): ?> title="<?php echo $this->__($this->getImgAlt()) ?>"<?php endif; ?> alt="<?php echo $this->__($this->getImgAlt()) ?>” />
<?php if($this->getLinkUrl()): ?>
</a>
<?php endif ?>
</div>
</div>

 
Magento Community Magento Community
Magento Community
Magento Community
 
kdigennaro
Member
 
Total Posts:  47
Joined:  2012-05-20
 

Hey Stan,
My guess is that it has to do with the right call out.

<div class="block block-banner">
<
div class="block-content">
<?php if(strtolower(substr($this->getLinkUrl(),0,4))==='http'): ?>
<a href="<?php echo $this->getLinkUrl() ?>” title="<?php echo $this->__($this->getImgAlt()) ?>">
<?php elseif(
$this->getLinkUrl()): ?>
<a href="
<?php echo $this->getUrl($this->getLinkUrl()) ?>” title="<?php echo $this->__($this->getImgAlt()) ?>">
<?php endif; ?>
<img src="<?php echo $this->getSkinUrl($this->getImgSrc()) ?>"<?php if(!$this->getLinkUrl()): ?> title="<?php echo $this->__($this->getImgAlt()) ?>"<?php endif; ?> alt="<?php echo $this->__($this->getImgAlt()) ?>” />
<?php if(
$this->getLinkUrl()): ?>
</a>
<?php endif ?>
</div>
</div>

This is calling for images in the right column my guess is that it would be the second to last image. So try cutting out this code and uploading and see which image it removes.

<div class="block block-banner">
<
div class="block-content">
<?php if(strtolower(substr($this->getLinkUrl(),0,4))==='http'): ?>
<a href="<?php echo $this->getLinkUrl() ?>” title="<?php echo $this->__($this->getImgAlt()) ?>">
<?php elseif(
$this->getLinkUrl()): ?>
<a href="
<?php echo $this->getUrl($this->getLinkUrl()) ?>” title="<?php echo $this->__($this->getImgAlt()) ?>">
<?php endif; ?>
<?php 
if($this->getLinkUrl()): ?>
</a>
<?php endif ?>
</div>
</
div>
 
Magento Community Magento Community
Magento Community
Magento Community
 
stanb17
Member
 
Total Posts:  34
Joined:  2010-06-02
 

SOLVED!!

Bazinga!!!

I cut out this…

<img src="<?php echo $this->getSkinUrl($this->getImgSrc()) ?>"<?php if(!$this->getLinkUrl()): ?> title="<?php echo $this->__($this->getImgAlt()) ?>"<?php endif; ?> alt="<?php echo $this->__($this->getImgAlt()) ?>” />
<?php if($this->getLinkUrl()): ?>
</a>
<?php endif ?>

And it worked perfectly in MSIE, Chrome, FF and I will check on Safari… just too happy to move from my desk.

THANK YOU SO MUCH for your time and patience. You are clearly an asset to the Magento community. A pleasure hunting with you.

Stan

 
Magento Community Magento Community
Magento Community
Magento Community
 
kdigennaro
Member
 
Total Posts:  47
Joined:  2012-05-20
 

Not a problem Stan I am glad I could help! It works fine in safari as well if you haven’t tested it yet. Please don’t hesitate to contact me if you have any other questions! Either here or via email.

Best Regards,
Kevin DiGennaro

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top