Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Constantly logs me out
 
bradyw
Jr. Member
 
Total Posts:  6
Joined:  2009-03-15
 

Loving Magento, but one big headache I’ve had is that the system constantly logs me out of admin. Sometimes after only 2-3 minutes of being logged in. I get to make one or two changes, and then am presented with the login screen again.

Fixes I’ve tried:
- Changing the admin_user extra field in the database to “N;” in phpMyAdmin. (re: http://720.com.au/web/?p=32)
- Setting the cookie expire time to a higher value

I’ve verified the server time is correct and that I have the same timezone selected in Locale Options.

I have installed the Offline Maintenance extension, but it doesn’t seem anyone else has the same problem with it. So I’m not sure that’s the cause, but thought I’d mention it just in case that helps.

Also, this is not a local install (I’ve noticed other threads related to this topic, but only applicable to local installs). Issue is happening in Firefox and Safari.

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Moderator
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

Would be curious who your ISP is and if your IP address changes frequently?

One thing to try is disabling some of the session validation settings:

admin -> system -> configuration -> web -> Session Validation Settings

I would start with setting Validate REMOTE_ADDR to No and seeing if you can reproduce the issue.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bradyw
Jr. Member
 
Total Posts:  6
Joined:  2009-03-15
 

Hi Skippy, thanks for the suggestion, though it turns out it’s still logging me out after about 5 mins even after setting that option to NO.

I have been working on this from a few ISP’s (home / work / even a remote developer who lives in Austria). The IP at work is static. Still same problem.

Any other ideas? I appreciate any help anyone might have.

Much thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
martinschm
Member
 
Total Posts:  56
Joined:  2008-03-03
 

Maybe its the session lifetime set in Magento. I also read about people having problems with sessions and they solved it by changing the way sessions are stored (there is a way of doing it on the file system). Check the Admin guide for more details on this.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bradyw
Jr. Member
 
Total Posts:  6
Joined:  2009-03-15
 

I believe I read what you are referring to, and the fix was to set some variable to ‘FILES’ . (Forgive my memory on this, I tried searching to bring up that thread again but couldn’t find it). I followed those instructions and turns out my config was already set as they described, so no help there.

If you can provide a link to the documentation regarding this, please do as I’ve tried searching and have so far come up with nothing.

Other people with similar problems in unresolved threads:
http://www.magentocommerce.com/boards/viewthread/11392/
http://www.magentocommerce.com/boards/viewthread/19445/

Hoping someone can help me out, my login-clicking finger is getting mighty tired these days.

-brady

 
Magento Community Magento Community
Magento Community
Magento Community
 
bradyw
Jr. Member
 
Total Posts:  6
Joined:  2009-03-15
 

bump truck.

hoping someone can help… i promise cupcakes! (actual cupcakes may vary)

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Moderator
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

Another couple of options are:

1) Set all session validation settings to no: (admin -> system -> configuration -> web -> Session Validation Settings)
2) Have your host check the server time/time zone and make sure it is correct and consistent with your computers time zone settings
3) Increasing session time to something like 86400 (24 hours)
4) Changing browsers (IE versus FireFox)

 
Magento Community Magento Community
Magento Community
Magento Community
 
bradyw
Jr. Member
 
Total Posts:  6
Joined:  2009-03-15
 

The only fix was to re-install Magento. Tried everything else and the re-install seems to have (so far) done the trick.

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Moderator
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

So no cupcakes ‘eh.. bummer

 
Magento Community Magento Community
Magento Community
Magento Community
 
bradyw
Jr. Member
 
Total Posts:  6
Joined:  2009-03-15
 

the cakes were a lie! rasberry

 
Magento Community Magento Community
Magento Community
Magento Community
 
vlad__k
Jr. Member
 
Total Posts:  3
Joined:  2013-09-05
 

For anyone still looking for a solution, system->configuration->admin -> select security tab and check session lifetime field - here you can define your time smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top