Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

404 error after purchasing ssl
 
chocopink
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2008-12-04
 

...my head is bloody, but unbowed…

To all the magento masters out there, please help.  I have been hosting my site on GoDaddy Delux Linux for months now while building it out.  I am at the point where I needed to purchase ssl so I can get google checkout to serve my needs until I have an actual payment gateway.  I purchased ssl through GoDaddy and now all of a sudden, my site wont load, front-or backend, what can I do?  My homepage will load, but no links off of the homepage will come up. I am not a web guru, I am just trying to learn as I go.  I checked permissions and they are fine, i just get a 404 error, not the 404 error in magento, but an IE 404 error.

I was hoping to launch this week, HELP!

Here is my site www.twiceenvyd.com/boutique

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Check the Secure/Unsecure Base URL settings in your Admin Panel. Does it contain ‘http://www.twiceenvyd.com/boutique/index.php/’ ? If you remove the ‘index.php’ part from the urls, it loads just fine, so it seems like the base url may be incorrect. I don’t see how this could have anything to do with the SSL, though.

 
Magento Community Magento Community
Magento Community
Magento Community
 
aephex
Jr. Member
 
Total Posts:  17
Joined:  2008-06-23
 

I am in the middle of dealing with the exact same thing. Godaddy shared hosting, happened once we installed their SSL.
3 or 4 days later they tell me it works fine if they disable my .htaccess file.

So,
I have been able to get the main page to show up by removing a certain line in my .htaccess file.

#RewriteEngine on

(I just commented it out)

However, I am still unable to get it to actually load any pages other than the index page.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chocopink
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2008-12-04
 
Sindre|ProperHost - 15 March 2009 09:55 AM

Check the Secure/Unsecure Base URL settings in your Admin Panel. Does it contain ‘http://www.twiceenvyd.com/boutique/index.php/’ ? If you remove the ‘index.php’ part from the urls, it loads just fine, so it seems like the base url may be incorrect. I don’t see how this could have anything to do with the SSL, though.

I wish I could check that, but I can’t log into the admin to do any of the that. Any other ideas???  This is very frustrating as I don’t want to have to start over from scratch.

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Moderator
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

If you are having the same problem as aephex, you can modify the .htaccess file either via FTP (it will be in the root directory where you installed Magento) or via GoDaddy web file manager.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

@chocopink: you can modify the base url settings directly in the database. Use a database management tool like phpMyAdmin or MySQL from the command line via SSH to locate the following records:

SELECT FROM core_config_data WHERE path like '% base_url%';

This will allow you to view or update the value of the base url.

 
Magento Community Magento Community
Magento Community
Magento Community
 
aephex
Jr. Member
 
Total Posts:  17
Joined:  2008-06-23
 

After a little more digging around in the .htaccess file in my root directory I was able to come up with one that works.

Options +FollowSymLinks

RewriteEngine On

RewriteBase 
/

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l
RewriteRule 
index.php [L]

Options +FollowSymLinks is the important part.

Most of this is documented on the site, either in the forums or the wiki, but until I was willing to completely scrap my old .htaccess file it didn’t like it.

Let me know if it works for you as well.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chocopink
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2008-12-04
 
aephex - 16 March 2009 09:09 AM

After a little more digging around in the .htaccess file in my root directory I was able to come up with one that works.

Options +FollowSymLinks

RewriteEngine On

RewriteBase 
/

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l
RewriteRule 
index.php [L]

Options +FollowSymLinks is the important part.

Most of this is documented on the site, either in the forums or the wiki, but until I was willing to completely scrap my old .htaccess file it didn’t like it.

Let me know if it works for you as well.

Ok, I’ll let you know what happens…

 
Magento Community Magento Community
Magento Community
Magento Community
 
chocopink
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2008-12-04
 
Sindre|ProperHost - 15 March 2009 10:40 PM

@chocopink: you can modify the base url settings directly in the database. Use a database management tool like phpMyAdmin or MySQL from the command line via SSH to locate the following records:

SELECT FROM core_config_data WHERE path like '% base_url%';

This will allow you to view or update the value of the base url.

Thanks for your response, I am going to try this htaccess thing and if a no go, i’ll try to figure out how to do this.  Thanks again!

 
Magento Community Magento Community
Magento Community
Magento Community
 
chocopink
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2008-12-04
 

Ok so I’m getting nowhere...FAST!!!

Attached are my settings for my database and it shows the base url’s as www.twiceenvyd.com/boutique which is correct.  I also tried the htaccess fix to no avail.  Here is exactly what I did, I cut and paste the text in the suggestion above into a notepad file and then saved it and uploaded the file to my root folder and rename it to .htaccess (which replaced the orignal one).  That did not work unless of course I did it wrong. 

I am near tears… Please HELP!!!

Image Attachments
screenshot.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
chocopink
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2008-12-04
 

So… after gathering up the courage to play around with the files, I followed the instructions found in this thread http://www.magentocommerce.com/boards/viewthread/5023/

And don’t you know it, I got my site back.  cheese

Thank you all for your input and insight.  I really appreciate it! I hope this can help someone else out.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top