Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

multiple apache2 processes site times out after a few hours of running
 
assault
Jr. Member
 
Total Posts:  6
Joined:  2009-02-23
 

Let me just start by saying I’ve got nothing but love for Magento, but I’ve been having one problem with a site that we had tested and worked on pretty thoroughly that is now live and we have been having problems with it here all day. (Browser time outs after a few hours of it running and we have to restart apache)

http://www.assaultshirts.com

As far as I can tell I have a normal .htaccess file with a handful of PermanentRedirects from my old site (I even enabled all the caching options in the admin and on the htaccess file) and I still have this periodically happen from time to time.

I meet all the requirements as far as server goes, I’m on a LAMP setup with PHP 5.2 and the newest version of Mysql and Apache2

I have a ton of www-data processes and I feel like there’s some sort of loop that’s happening with all the processes that are launched?

www-data 29101 0.0 0.3 27296 6016 ?  S 17:55 0:00 /usr/sbin/apache2 -k start
www-data 29103 0.5 2.8 97388 44208 ?  S 17:55 0:07 /usr/sbin/apache2 -k start
www-data 29104 0.5 2.8 97972 44692 ?  S 17:55 0:07 /usr/sbin/apache2 -k start
www-data 29107 0.9 2.5 91232 39644 ?  S 17:55 0:12 /usr/sbin/apache2 -k start
www-data 29109 0.3 2.4 96952 38564 ?  S 17:55 0:04 /usr/sbin/apache2 -k start
www-data 29110 0.4 2.5 93208 39504 ?  S 17:55 0:05 /usr/sbin/apache2 -k start
www-data 29124 0.4 2.8 98092 44380 ?  S 17:55 0:05 /usr/sbin/apache2 -k start
www-data 29128 0.0 1.8 96596 28476 ?  S 17:56 0:00 /usr/sbin/apache2 -k start
www-data 29192 1.3 2.4 93024 37480 ?  S 18:00 0:12 /usr/sbin/apache2 -k start
www-data 30214 0.5 2.6 97388 41344 ?  S 18:04 0:04 /usr/sbin/apache2 -k start
www-data 30225 0.5 2.0 91304 32396 ?  S 18:05 0:03 /usr/sbin/apache2 -k start
www-data 30228 0.1 1.8 96340 28308 ?  S 18:05 0:00 /usr/sbin/apache2 -k start
www-data 30229 0.0 1.8 96648 28240 ?  S 18:05 0:00 /usr/sbin/apache2 -k start
www-data 30234 0.9 2.9 100332 45932 ?  S 18:06 0:06 /usr/sbin/apache2 -k start
www-data 30235 1.0 2.5 93668 39540 ?  S 18:06 0:06 /usr/sbin/apache2 -k start
www-data 30239 0.4 2.4 99804 38300 ?  S 18:06 0:02 /usr/sbin/apache2 -k start
www-data 30254 0.5 2.1 89248 33400 ?  S 18:08 0:02 /usr/sbin/apache2 -k start
www-data 30278 0.2 2.1 92380 32700 ?  S 18:10 0:01 /usr/sbin/apache2 -k start
www-data 30280 0.9 2.2 92832 35096 ?  S 18:10 0:03 /usr/sbin/apache2 -k start
www-data 30371 0.0 0.6 81880 10876 ?  S 18:16 0:00 /usr/sbin/apache2 -k start

Why would this happen? In my admin I do have caching enabled, and I do have enable server url rewrites with apache and the entire site seems to work:

http://www.assaultshirts.com

Any ideas anyone? Please help! We’re about to start running press for the site and I can’t be restarting apache every 2 hours!

 
Magento Community Magento Community
Magento Community
Magento Community
 
assault
Jr. Member
 
Total Posts:  6
Joined:  2009-02-23
 

Just thought I’d post an update to this problem, after about 2-3 days of tinkering with this we figured out that Magento was interfering with my wordpress blog in some way or another. I had installed the blog in the /blog directory of my root site and was running it off of a different domain name.

We moved it outside of my store directory, and everything seems to work fine. Beware users! Do not use a wordpress blog within a child directory of your Magento Installation!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top