Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Installation fails - SQLSTATE[42S02]: Base table or view not found
 
Sintax
Member
 
Total Posts:  58
Joined:  2008-02-18
Hungary
 

Hi,

I am trying to install magento 0.8.16100 on WindowsXP with Apache 2.2.6 and PHP 5.2. During the install I get the following error (and a bunch of messages above it):

exception ‘Mage_Core_Exception’ with message ‘Error in file: “C:\Apache2\htdocs\magento\app\code\core\Mage\Core\sql\core_setup\mysql4-install-0.7.0.php” - SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘magento.core_resource’ doesn’t exist’ in C:\Apache2\htdocs\magento\app\Mage.php:338
Stack trace:
#0 C:\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(260): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 C:\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(139): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’install’, ‘’, ‘0.7.5’)
#2 C:\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(126): Mage_Core_Model_Resource_Setup->_installResourceDb(’0.7.5’)
#3 C:\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(100): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 C:\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\Config.php(181): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 C:\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\App.php(174): Mage_Core_Model_Config->init(NULL)
#6 C:\Apache2\htdocs\magento\app\Mage.php(367): Mage_Core_Model_App->init(’base’, NULL)
#7 C:\Apache2\htdocs\magento\app\Mage.php(387): Mage::app(’base’, NULL)
#8 C:\Apache2\htdocs\magento\index.php(28): Mage::run(’base’)
#9 {main}

I tried PHP 5.2.5 but there I was getting PDO errors all over the place.

What is the problem?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bill007
Sr. Member
 
Avatar
Total Posts:  179
Joined:  2008-01-15
New Zealand
 

The first error will create the rest so look in the first few lines for your answer

It looks like one of the files is missing this can be the case often

look at the file structure in your down load zip file of Magento and compare with whats sitting on your server I have had files with 0 bytes sent before of files are just plain skipped

C:\Apache2\htdocs\magento\app\code\core\Mage\Core\sql\core_setup\mysql4-install-0.7.0.php start here

Bill Bailey

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top