Magento Forum

   
error when first install magento-0.8.16100
 
hxvb
Jr. Member
 
Total Posts:  3
Joined:  2008-02-17
 

He, excuse me for my English (it’s my third language).
This is my problem : I download the latest magento “magento-0.8.16100”, in order to test it, I’m using easyphp 1.8, and when I try to install it says that he need php 5.2, so I download and install the esayphp 2.0b1, and when I try to install it again I got this message:

<?=$this->__('Magento')?>
getChildHtml(’topSearch’)?>
getWelcome()?> getChildHtml(’topLeftLinks’)?>
getChildHtml(’topRightLinks’)?>
getChildHtml(’topMenu’)?>
getChildHtml(’store’)?>
getChildHtml(’breadcrumbs’)?>
getChildHtml(’left’)?>
getChildHtml(’global_messages’)?> getChildHtml(’content’)?>
__(’Help Us to Keep Magento Healthy’)?> - __(’Report All Bugs’)?> __(’(ver. %s)’, Mage::getVersion())?>
__(’Magento™ is a registered Trademark of Irubin Consulting Inc. DBA Varien. © Copyright 2007’)?>

I don’t understand this error category to find out the solution in the forum, please forgive me.
Environment: win xp sp2, esayphp 2.0b1.
Think you for helping me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bill007
Sr. Member
 
Avatar
Total Posts:  179
Joined:  2008-01-15
New Zealand
 

It looks like your php upgrade has not taken effect
It is just plain not reading the php code

Bill Bailey

 
Magento Community Magento Community
Magento Community
Magento Community
 
hxvb
Jr. Member
 
Total Posts:  3
Joined:  2008-02-17
 

thnx, ok then! what i have to do to make it work?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JDoyle
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2007-11-20
 

Hi,
it may be to do with short tags not being active - which produced the same error during my install.

Ensure the following statement is present in your php.ini file:

php_flag short_open_tag on

If you don’t have access to the php.ini file (e.g. if you are on shared hosting) then the following may work:
My host allows you to add your own php.ini file (or php5.ini) into your shared hosting root directory. The commands in this file overwrite the core php.ini file so you can just put the statement above into this new file (i.e. just this statement on its own with nothing else in the file).
I did read somewhere that you can also put this statement in the .htaccess file but this didn’t work for me so not sure if it’s correct.

hope this helps,
Jeremy

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bill007
Sr. Member
 
Avatar
Total Posts:  179
Joined:  2008-01-15
New Zealand
 

Yep
On thinking about it that is a default setting short Tags off

I think you are right there JD

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rex148
Jr. Member
 
Total Posts:  8
Joined:  2008-02-15
 

I’m having the same error. When i went into the page code, i found that some ending tags ?> are missing. Let me turn on the short tags setting and see how it works. I’ll update you asap.
Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Rex148
Jr. Member
 
Total Posts:  8
Joined:  2008-02-15
 

yes, this is the case! I turn the short tags setting on, and it works!

 
Magento Community Magento Community
Magento Community
Magento Community
 
hxvb
Jr. Member
 
Total Posts:  3
Joined:  2008-02-17
 

Hi, thank you for helping me, I turn the short_open_tag on and I was able to run the install page, then I get this page (img1attachements), I ignore the problem and click continue and I get this page (img2 attachements), apparently there is an extension need to be run, so I go to esayphp extension window and I get this (img3 attachements), the extension in red cannot be run because of dependency errors. sorry for that, please any solutions.

Image Attachments
img1.JPGimg2.JPGimg3.JPG
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top