Magento Forum

SSL Verschlüsselung lässt den Shop abstürzen
 
Lulabaer
Jr. Member
 
Total Posts:  7
Joined:  2013-03-21
 

Hallo, ich verzweifele gerade an den Einstellungen für die SSL Verschlüsselung, folgendes Problem:

Wir haben ein Zertifikat direkt bei unserem Provider gebucht, das liegt auf unserer Domain. Beim Provider kann ich einstellen, das dort immer von http:// auf https:// umgeleitet werden soll. Habe ich diese Einstellung aktiviert, habe ich natürlich im gesamten Shop eine Verschlüsselung und erhalte eine Sicherheitswarnung wenn ich auf einer Produktdetailseite etwas in den Warenkorb legen will und komme dort nicht weiter.

Deaktiviere ich die Funktion beim Provider funktioniert gar nichts mehr, egal welche Einstellungen ich im Magento Backend unter Web - Sicher mache. Die Seiten werden nicht aufgerufen, es gibt Endlosschleifen, auf Unterseiten wirde die CSS nicht korrekt geladen, Buttons funktionieren nicht uvm…

Ich habe bereits beim Provider um Hilfe gebeten - der empfiehlt auf jeden Fall die Deaktivierung von http:// auf https:// und die Einstellung über das Magento Backend, aber das geht ja mal gar nich..

Habe schon überall gesucht, finde viele Probleme zum Thema SSL, aber für mich keinen Lösungsansatz, wer kann helfen?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lulabaer
Jr. Member
 
Total Posts:  7
Joined:  2013-03-21
 

Habe gerade noch einen Hinweis vom Provider erhalten:

mit aktivierten SSL findet kein Varnish Caching statt. Die Seite versucht seine Daten über normales http zu verschicken

Das würde ja doch bedeuten, meine Backend-Einstellungen sind nicht korrekt, ich habe aber alles durchprobiert und mich an offizielle Anleitungen gehalten:
Unter Sicher Basis-URL: https://meinedomain.de/ (Dafür ist auch das Zertifikat) und gleiche Einstellung unter https://meinedomain.de/skin usw. und unter
Verwende sichere URL im Shopbereich: Nein
Was sonst noch? Benötige dringend einen Ansatz, wo ich suchen soll…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lulabaer
Jr. Member
 
Total Posts:  7
Joined:  2013-03-21
 

Und noch ein Hinweis, denn ich versuche mich ja auch selbst an das Problem heranzutasten:

Zwischendurch hat alles kurz prima funktioniert - also können meine Einstellungen nicht so falsch gewesen sein, allerdings nach Löschen des Browsercaches doch wieder Probleme.

Inzwischen bin ich ein kleines Stück weiter: Ich habe die Einstellungen beim Provider, wie vom Provider empfohlen und in Magento ebenso. Jetzt läuft der Shop und wird nicht mehr auseinandergehauen aber er löst tatsächlich nicht auf die https auf sondern bleibt auch im Bestellvorgang unverschlüsselt. Ich bin jetzt absolut ratlos und hoffe weiter auf Hilfe…

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top