Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Artikel werden nicht in Kategorie angezeigt
 
flo1210
Jr. Member
 
Total Posts:  6
Joined:  2008-07-23
 

Hallo,

folgendes Problem.
Habe verschiedene Produktkategorien,
in diesen Kategorien sind auch Artikel vorhanden.
Mit aktuellen firefox und auch mit aktuellen Safari werden diese Artikel auch angezeigt.

Leider wird wenn man sich den Shop über IE6 oder IE7 anschaut immer nur der 1. Artikel in der Kategorie angezeigt..
Die restlichen sind nicht in der Kategorie.

Wo liegt mein denk fehler?
Kann mir jemand weiterhelfen?

Viele Grüße und danke im voraus.

Nachtrag der Fehler tritt nur auf wenn die Ansicht auf Gitter eingestellt ist…
Wenn Artikel in listenform angezeigt werden dann geht es…

 
Magento Community Magento Community
Magento Community
Magento Community
 
ds_1984
Mentor
 
Avatar
Total Posts:  3116
Joined:  2008-12-09
Potsdam, Germany
 

Das ist typisch IE - in allen läufts und die Kiste streikt schon wieder. Kenne das Problem im Verhältniss mit floatenden Elementen in CSS. Als Quick und Dirty Lösung kannst du im Backend umstellen auf “nur Liste”. Ich meine es ist unter System/Konfiguration/Katalog irgendwo.

LG - Daniel

 
Magento Community Magento Community
Magento Community
Magento Community
 
Dscho
Sr. Member
 
Avatar
Total Posts:  236
Joined:  2007-10-05
Singen, Germany
 

Hi,

ich vermute auch einen CSS-Fehler - allerdings kann man das so aus der Ferne und ohne Beispiel
schlecht beurteilen. Hast Du einen Link zu Deinem Shop?

Gruß
Dscho

 
Magento Community Magento Community
Magento Community
Magento Community
 
s-A-m
Jr. Member
 
Avatar
Total Posts:  4
Joined:  2010-08-09
Ulm
 

Hallo liebe Magento-Entwickler,

ich habe ebenfalls ein Problem mit der Darstellung der Artikelseite. Wenn man es genau nimmt sind es sogar 2 Probleme an dennen ich mir mittlerweile die Zähne ausbeisse.

1. Bei anlegen eines Artikels in eine Kategorie konnte ich die Artikelseite nicht aufrufen - folge war eine Errormessage. Nach langem gegoogle musste ich feststellen, dass das Theme welches ich verwende einige Probleme in sich birgt. Nach weiteren Stunden sties ich auf einen Post mit Link zu einer angepassten Version meines Themes (f001/f002). Nach erfolgreichem austauschen der files in das /app/ Verzeichnis und anpassen der headerdatei - siehe der bereits angelegte Artikel ist nun sichtbar: http://www.saarweb24.de/men/men-schuhe/sport-jogging.html

Das jetztige Problem besteht darin, dass neu angelegte Artikel unter der Anpassung im fronted nicht gefunden werden:
http://www.saarweb24.de/women/schuhe/walking-jogging.html

Es ist zum Mäusemelken - leider finde ich auch keinen passenden Post der mir da weiterhilft.

2. Wenn ich auf das Produkt klicke und mir die Detailseite anschauen möchte erhalte ich leider immernoch die Errormessage:
http://www.saarweb24.de/men/men-schuhe/sport-jogging/adidas-dumaro2-joggingschuh-blau-weiss-silber.html

Ich habe die Errorfile so eingestellt das ich den Fehlercode direkt sehe - falls irgendjemand da draussen eine Lösung parat hat ich wäre ihm wirklich sehr sehr dankbar smile

LÖSUNG:

1. Manchmal sieht man den Wald vor lauter Bäumen nicht smile

Produkte verwalten -> Produktinformation -> Lagerverwaltung

1. Menge darf nicht 0 sein
Hatte ich erhöht, zunächst ohne Erfolg

2. Lagerbestand: Auf Lager gesetzt

Siehe da, die Produkte sind sichtbar
Magento 1.4.1.0

Allerdings wird die Produktdetailseite immer noch nicht angezeigt :( aber wo ein Fehler da sicherlich auch eine Lösung smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top