Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problemas com o URL rewrite
 
PedroTeixeira
Sr. Member
 
Avatar
Total Posts:  136
Joined:  2008-05-28
Berlin, Germany
 

Olá Pessoal,

Acabei de fazer uma nova instalação do Magento e na instalação falei que gostaria de usar o rewrite....Mas minhas URL’s estão assim:

http://loja.com.br/catalog/product/view/id/166/s/htc-touch-diamond/

Em Configurações > Web > Opções de URL está sim e em Configurações > Catálogo > Search Engine Optimizations está tudo habilitado e com o sufixo configurado.

Alguém sabe o que pode ser?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Adriano Aguiar
Moderator
 
Avatar
Total Posts:  343
Joined:  2008-08-26
Sao Paulo
 

@Pedro, acredito que o ideal seja:

Sistema > Configuração > [Geral] > Web > Otimização de Mecanismos de Busca > Usar Web Server Rewrite definido como “Não”.

Em Sistema > Configuração > [Catálogo] > Catálogo > Otimização de Mecanismos de Busca:

- Termos de Busca Populares: Habilitar
- Mapa do Site Gerado Automaticamente: Habilitar
- Product URL Suffix: .html (opcional)
- Usar caminho de categorias para URLs do produto: Sim
- Separados de Título da Página: - (hífen)

Agora na sua base de dados, na tabela core_url_rewrite, faça um backup e depois apage todos os registros dela, após este processo faça a limpeza do cache.

Valeu!

 
Magento Community Magento Community
Magento Community
Magento Community
 
PedroTeixeira
Sr. Member
 
Avatar
Total Posts:  136
Joined:  2008-05-28
Berlin, Germany
 

Funcionou Adriano!

Mas notei uma outra coisa.....que agora todas URL’s ficam o “index.php” na frente.

Lembro que quando tentei resolver esse problema modifiquei alguma coisa pra fazer isso...mas não lembro o que. Voce sabe oq pode ser?

Abraços!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Adriano Aguiar
Moderator
 
Avatar
Total Posts:  343
Joined:  2008-08-26
Sao Paulo
 

Entendo @Pedro, dá uma olhada nessa thread:

http://www.magentocommerce.com/boards/viewthread/37543/

Basicamente, acredito que após essas configurações você tenha que fazer o processo: Sistema > Configuração > [Geral] > Web > Otimização de Mecanismos de Busca: “Sim”.

Agora acesse:

http://felipetonello.com/blog/tutoriais-e-artigos/tutorial-zend-framework/

Este tutorial do felipe ele comenta sobre algumas configurações que você deve aplicar no httpd.conf do seu apache.

Eu defini assim:

Apache:

<Directory />
Options Indexes FollowSymLinks
AllowOverride None
</Directory>

Minha configuração:

<Directory />
Options FollowSymLinks Includes
AllowOverride All
Order deny,allow
Deny from all
</Directory>

Espero ter ajudado! o/

 
Magento Community Magento Community
Magento Community
Magento Community
 
PedroTeixeira
Sr. Member
 
Avatar
Total Posts:  136
Joined:  2008-05-28
Berlin, Germany
 

Perfeito Adriano.

Consegui fazer funcionar!

Abraços!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top