Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Don’t work with security permissions and work with 777
 
seromenho
Jr. Member
 
Total Posts:  3
Joined:  2012-12-02
 

Version: Magento 1.7.0.2 community

I have installed magento on my server and set 777 permissions to all.
Now, I have “finished” the setup and adding products and want to go to production.
I have moved the base dir to the proper path and changed the URL and it works well.
Next I want to change the permissions to what’s in Magento Filesystem Permissions.
Via SSH i have done (escaped;, otherwise won’t work)

find . -type d -exec chmod 775 {} \;
find . -type f -exec chmod 664 {} \;
After doing this I got a diferente shop. Like the one in the begining. No products and no theme.
If I change the permissions back to 777 i get everything again.

EDIT:
Tried

find . -type d -exec chmod 775 {} \;
and let files 777 it doesn’t work.

find . -type f -exec chmod 664 {} \;
and let directories 777 and it worked

What is missing me?
Thank you

 
Magento Community Magento Community
Magento Community
Magento Community
 
seromenho
Jr. Member
 
Total Posts:  3
Joined:  2012-12-02
 

Resolved:
I have changed the files and folders owner to the apache user.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top