Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 4 of 4
Barebones Guide: 1and1.com Shared Hosting Installation (North America)
 
lisali
Enthusiast
 
Avatar
Total Posts:  889
Joined:  2008-04-28
London, UK
 

Just one question regarding the 1and1 installation guide here. It says to CHMOD to 777 the following:

[dir] magento/app/etc
[dir] magento/var
[file] magento/var/.htaccess
[dir] magento/media

However, the Magento Installation guide just says:

Ensure that the directories app/etc , var , and media are writable by the web server.

It does NOT say anything about the var/.htaccess file. It also does not say if only the main directories above should be CHMOD-ed to 777, or if it should apply to all sub-directories and contained files?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
bardocz
Jr. Member
 
Total Posts:  4
Joined:  2009-01-08
 

Sorry wrong topic..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Daniel_le_Rouge
Jr. Member
 
Total Posts:  1
Joined:  2009-04-04
 

Hi!

Our company wants to switch to Magento. We are using 1&1;. I followed your instructions several times and adjusted .htaccess and pear, but I still get the same error messages. If I do it over SSH I receive the error message that I use PHP4 even despite using the modified .htaccess and pear data.

The web interface tells me the following:

magento-core/Mage_Pear_Helpers requires package "pear/PEAR" (version >= 1.6.2)
magento-core/Lib_Google_Checkout requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Mage_Core_Modules requires package "magento-core/Lib_Google_Checkout" (version >= 1.2.0version <= 1.3.1excluded versions1.3.1)
magento-core/Mage_All_Latest requires package "magento-core/Mage_Core_Modules" (version >= 1.3.0version <= 1.3.0)
magento-core/Mage_Core_Adminhtml requires package "magento-core/Mage_Core_Modules" (version >= 1.3.0version <= 1.3.0)
magento-core/Interface_Adminhtml_Default requires package "magento-core/Mage_Core_Adminhtml" (version >= 1.3.0version <= 1.3.0)
magento-core/Interface_Frontend_Default requires package "magento-core/Mage_Core_Modules" (version >= 1.3.0version <= 1.3.0)
magento-core/Interface_Install_Default requires package "magento-core/Mage_Core_Modules" (version >= 1.3.0version <= 1.3.1excluded versions1.3.1)
magento-core/Lib_Js_Calendar requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Lib_Js_Prototype requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Mage_Downloader requires package "magento-core/Lib_Js_Prototype" (version >= 1.2.0version <= 1.2.0)
magento-core/Lib_Js_Mage requires package "magento-core/Lib_Js_Prototype" (version >= 1.2.0version <= 1.3.1excluded versions1.3.1)
magento-core/Lib_Js_Ext requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Lib_ZF requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Lib_Varien requires package "magento-core/Lib_ZF" (version >= 1.7.2.2version <= 1.7.3excluded versions1.7.3)
magento-core/Lib_ZF_Locale requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)

Install Errors
No valid packages found
PEAR ERROR
install failed

I don’t really know what to do. I contacted 1&1;, but I don’t think that they can help me (bad experiences). May anybody help me?

Thanks a lot! Daniel

 
Magento Community Magento Community
Magento Community
Magento Community
 
Vincent Young
Jr. Member
 
Total Posts:  3
Joined:  2009-02-28
 

I need help/a solution and will compensate monetarily.

I’m using Magento ver. 1.2.1.2 on 1and1 shared host with SSL purchased through them (GeoTrust).  I was instructed to add:

RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^(.*)$ https://www.classics-clothing.com/$1 [R]

in the .htaccess file to get SSL working.  Now when this happens an ugly SID came up in the URL and could not navigate to any of my pages.  I changed some things around in the configuration -> web section and can no longer log-in to the site.  Going to bed and will look at database tomorrow so I can log back in.  Need to get this store up and running asap.  SSL is the last thing i need to work out.

Any help would be appreciated and have no problem paying whatever your rate is and however long it takes.  Just send me a holler.

Cheers all.

-Vinnie

 
Magento Community Magento Community
Magento Community
Magento Community
 
lisali
Enthusiast
 
Avatar
Total Posts:  889
Joined:  2008-04-28
London, UK
 

Hi Vinnie,

There’s no need to add that .htaccess rule. I am on the same setup, and it works fine here. Just remove those lines.

Good luck!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady Barrows
Jr. Member
 
Total Posts:  29
Joined:  2009-09-17
 

I have read through as many threads as I can and when i install Magento 1.3.2.3 I get a blank white page and then I go back in my browser and this error message comes up:

Error in file: “/homepages/38/d104790298/htdocs/magento/magento/app/code/core/Mage/Downloadable/sql/downloadable_setup/mysql4-upgrade-0.1.6-0.1.7.php” - SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘downloadable_link’ already exists
Trace:
#0 /homepages/38/d104790298/htdocs/magento/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(292): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /homepages/38/d104790298/htdocs/magento/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(179): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘0.1.6’, ‘0.1.14’)
#2 /homepages/38/d104790298/htdocs/magento/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(146): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(’0.1.6’, ‘0.1.14’)
#3 /homepages/38/d104790298/htdocs/magento/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(121): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /homepages/38/d104790298/htdocs/magento/magento/app/code/core/Mage/Core/Model/Config.php(263): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /homepages/38/d104790298/htdocs/magento/magento/app/code/core/Mage/Core/Model/App.php(263): Mage_Core_Model_Config->init(Array)
#6 /homepages/38/d104790298/htdocs/magento/magento/app/Mage.php(434): Mage_Core_Model_App->init(’’, ‘store’, Array)
#7 /homepages/38/d104790298/htdocs/magento/magento/app/Mage.php(455): Mage::app(’’, ‘store’, Array)
#8 /homepages/38/d104790298/htdocs/magento/magento/index.php(65): Mage::run()
#9 {main}

Please help me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady Barrows
Jr. Member
 
Total Posts:  29
Joined:  2009-09-17
 

Ok, I kept reading and found I needed the cgi-bin folder and the php5 - cgi file in the folder. I did that. I went through the install again and now I get this error message:

Error 500 - Internal server error

An internal server error has occured!
Please try again later.

I think it has to do with the fact I started the install and I need to start from scratch again. How can I remove the settings and use the install again?

 
Magento Community Magento Community
Magento Community
Magento Community
 
nasha
Sr. Member
 
Avatar
Total Posts:  138
Joined:  2009-04-15
 

@Airforce111 thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Federico Gomez
Jr. Member
 
Total Posts:  1
Joined:  2010-02-04
 

I need to install magento ver. 1.3.2.4 on 1and1 shared hosting

Hi, ive been reading lot of threads but i didn´t find the solution to install Magento on 1&1;(1and1.com) shared hosting

the problem during installation:

1.  i accept the agreement, and on the next screen (Localization):

Locale *

Fatal error: Out of memory (allocated 5505024) (tried to allocate 16 bytes) in /homepages/7/dxx6296445/htdocs/domain.com/4/magento/app/code/core/Mage/Core/functions.php on line 239

- so i refresh and it seems to pass ok

2. on the configuration, after fill the info of database, etc and click continue:

magento/report/?id=-395239967&s;=default

There has been an error processing your request.
Error in file: “/homepages/7/dxx6296445/htdocs/domain.com/4/magento/app/code/core/Mage/Core/sql/core_setup/mysql4-install-0.8.0.php” - SQLSTATE[HY000]: General error: 1005 Can’t create table ‘./db316900661/#sql-12bc_6a7352.frm’ (errno: 121)
Trace:
#0 /homepages/7/dxx6296445/htdocs/domain.com/4/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(292): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /homepages/7/dxx6296445/htdocs/domain.com/4/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(167): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’install’, ‘’, ‘0.8.13’)
#2 /homepages/7/dxx6296445/htdocs/domain.com/4/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(155): Mage_Core_Model_Resource_Setup->_installResourceDb(’0.8.13’)
#3 /homepages/7/dxx6296445/htdocs/domain.com/4/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(121): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /homepages/7/dxx6296445/htdocs/domain.com/4/magento/app/code/core/Mage/Core/Model/Config.php(263): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /homepages/7/dxx6296445/htdocs/domain.com/4/magento/app/code/core/Mage/Core/Model/App.php(263): Mage_Core_Model_Config->init(Array)
#6 /homepages/7/dxx6296445/htdocs/domain.com/4/magento/app/Mage.php(434): Mage_Core_Model_App->init(’’, ‘store’, Array)
#7 /homepages/7/dxx6296445/htdocs/domain.com/4/magento/app/Mage.php(455): Mage::app(’’, ‘store’, Array)
#8 /homepages/7/dxx6296445/htdocs/domain.com/4/magento/index.php(65): Mage::run()
#9 {main}

then stop the installation and i have to remove all files and drop the database to get a new installation.

 
Magento Community Magento Community
Magento Community
Magento Community
 
timpletcher
Jr. Member
 
Avatar
Total Posts:  12
Joined:  2010-03-24
 

Very cool, you can also find screenshot tutorials for magento commerce installation help.  Sometimes thats a big help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
citacomp
Jr. Member
 
Total Posts:  8
Joined:  2011-05-22
 

I was able to install 1.5.1.0 on 1and1 shared hosting without many problems. The stupid 500 error would come up and go away with a few page refreshes. I have been getting the memory error once and awhile, but I activated the php.ini file and the memory failure errors have gone away. Now sometimes the page keeps loading and loading and loading (even white the whole time). Makes it harder when 1and1 wont let us have access to any error log.

 
Magento Community Magento Community
Magento Community
Magento Community
 
paradigmtest
Jr. Member
 
Total Posts:  27
Joined:  2011-08-18
 

Thanks for this guide. It\’s a bit old, but helpful.

As of August 26, 2011 1&1;(1and1.com) is starting to offer new plans that allow a 1 click and build install of magento.

I\’ve signed up for one of these plans and they temporarily disabled the easy install.
They said they are working out a bug and will have the install available again soon.

In the meantime, I\’m installing Magento using the following guides and seeing how it runs on 1&1;…

http://www.magentocommerce.com/wiki/welcome_to_the_magento_user_s_guide/chapter_2
http://www.magentocommerce.com/knowledge-base/entry/magento-installation-cheat-sheet/
http://www.magentocommerce.com/wiki/3_-_store_setup_and_management/so_you_want_a_real_store_and_not_a_demo

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 4 of 4