Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Suddenly products are not being added to the cart in IE7
 
XPSM1730
Member
 
Total Posts:  70
Joined:  2008-02-27
 

Hi,

I get to see a “nothing in your cart” message when i click on the add to cart button. This seems only to be happening with internet explorer.

I thought there might be something wrong with the cache so i tried to disable it. It failed and showed me a Warning: chmod() [function.chmod]: Operation not permitted.

i tried

chown apache app/etc/use_cache.ser

That fixed the chmod permission error but the products are still not being added to the cart.

Then i tried

chown apache *

But still the products are not being added to the cart.

What can be the cause of this problem? This store has been running for 8 months in a row without a single problem. Maybe my system messed up something but i don’t know where to look.

I hope someone can help me out a bit because my sales are plummeting!

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ready Eddy
Jr. Member
 
Avatar
Total Posts:  7
Joined:  2008-09-23
 

Have you had any luck finding a solution to this problem.  I seem to have the same issue.  The entire site including admin all function correctly in FF3 but the following does not work in IE7.

- Admin login
- Customer Login
- Add item to Cart

All of this started happening over the weekend.  There haven’t been any code changes, but there was a server restart?  Would that cause the issue?

I have been banging my head on this for the past several hours without any luck.  Were you able to find a solution?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ready Eddy
Jr. Member
 
Avatar
Total Posts:  7
Joined:  2008-09-23
 

The solution that worked for me was to change the cookie_lifetime setting in system->configuration->general->web.

I changed it from 3600(1hr) to 86400(24hr) and all worked fine.

I guess IE validates the times in the cookies a little different.

Hope this helps!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top