Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Administrator can’t login - page refresh with no error. 
 
kevinusingmagento
Jr. Member
 
Total Posts:  6
Joined:  2009-03-05
 

I downloaded and installed a copy of magento, everything was working fine - added categories, products other users etc.. then I was kicked out with a timeout message (can’t recall the error - did not think it was important). Then I tried to re-login but it did not work, just a page refresh.

here’s some of the things I checked/tried. (but can’t get it to work, very frustrating !)
- reset password (duh!)
- made sure php.ini had error logging on, no messages in syslog
- restarted apache
- restarted server (it’s a VM)
- no relevant messages in any of the apache logs
- I deleted all session and cache files, cleared and restarted browser.
- tried different browsers (chrome, firefox)
- tried different computers
- I found a script that added usr/psw toto/toto which is used in case of password loss, this did not work (the script worked, you just can’t login with toto/toto)
- I swapped databases - I had a previous install of magento with test data (which worked) so I switch the current web install to use that old db (cleared cache etc..) I can see the sample data in the front end but still not able to login backend.

so how to proceed...?
how can I get some debug information to find outs what’s wrong

 
Magento Community Magento Community
Magento Community
Magento Community
 
aclark
Jr. Member
 
Total Posts:  2
Joined:  2009-03-05
 

I’m having this same issue and was able to get in by using Safari rather than Firefox.  Still can’t get Firefox to let me in.

 
Magento Community Magento Community
Magento Community
Magento Community
 
SoopaDoopa
Jr. Member
 
Total Posts:  3
Joined:  2008-10-12
Australia
 

Same problem here too. Have tried with Firefox 3, Safari 4, both on Mac OS X 10.5.6.

 
Magento Community Magento Community
Magento Community
Magento Community
 
SoopaDoopa
Jr. Member
 
Total Posts:  3
Joined:  2008-10-12
Australia
 

Ok, found *my* problem. I had put an incorrect value into the cookie_domain setting. I managed to fix this by logging into the MySQL db directly and fixing. Hope this helps someone else!

 
Magento Community Magento Community
Magento Community
Magento Community
 
kevinusingmagento
Jr. Member
 
Total Posts:  6
Joined:  2009-03-05
 

bizarre thing is I tried today - NO CHANGES AT ALL - and it works again !

something is fishy, would love to be able to debug further if it happens again - will keep testing.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kevinusingmagento
Jr. Member
 
Total Posts:  6
Joined:  2009-03-05
 

Well now firefox works - chrome does not - (would customers have same joyful experience)

 
Magento Community Magento Community
Magento Community
Magento Community
 
kevinusingmagento
Jr. Member
 
Total Posts:  6
Joined:  2009-03-05
 

and now after timeout can’t login with firefox again AGHHHH!

 
Magento Community Magento Community
Magento Community
Magento Community
 
kevinusingmagento
Jr. Member
 
Total Posts:  6
Joined:  2009-03-05
 

Ok, set the cookie to = url (I am running on IP address and had set future domain as cookie) , cleared cache and session and can login again on firefox (SoopaDoopa thx)

just in case anyone wants to do that
update core_config_data set value="YOURCOOKIEDOMAIN “ where path="web/cookie/cookie_domain";

but still does not work on chrome (must check customer login) - works on IE and Firefox.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kevinusingmagento
Jr. Member
 
Total Posts:  6
Joined:  2009-03-05
 

yep..customer can’t login with chrome either, not a good thing.

No alerts, no errors..bye bye customer.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chopstik
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2008-08-07
Northland, Aoteoroa
 

I struck the same issue. To fix I cleared both path values in the database in the `core_config_data` table:
web/cookie/cookie_domain
web/cookie/cookie_path

I then emptied the /var/cache directory, and then the admin login works correctly again.

I came to this error in the same manner - I added an incorrect Cookie Domain in the configuration.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top