Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problema Modulo di spedizion e fattura
 
Xeon
Jr. Member
 
Total Posts:  27
Joined:  2009-02-25
 

Avevo creato,seguendo la guida,un nuovo modulo di spedizione.Era soltanto per provarlo,infatti alla fine ho deciso di rimuoverlo.Il problema ora è che mi ha combinato un bel pasticcio perchè quando in un ordine effettuato clicco sul pulsante Fattura o Spedisci mi esce questo errore:

Invalid model for shipping method: carrier_name
Trace:
#0 C:\wamp\www\magento\app\code\core\Mage\Shipping\Model\Config.php(90): Mage::exception(’Mage_Shipping’, ‘Invalid model f...’)
#1 C:\wamp\www\magento\app\code\core\Mage\Shipping\Model\Config.php(61): Mage_Shipping_Model_Config->_getCarrier(’carrier_name’, Array, ‘1’)
#2 C:\wamp\www\magento\app\code\core\Mage\Adminhtml\Block\Sales\Order\Shipment\Create\Tracking.php(75): Mage_Shipping_Model_Config->getAllCarriers(’1’)
#3 C:\wamp\www\magento\app\design\adminhtml\default\default\template\sales\order\shipment\create\tracking.phtml(91): Mage_Adminhtml_Block_Sales_Order_Shipment_Create_Tracking->getCarriers()
#4 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(144): include(’C:\wamp\www\mag...’)
#5 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(176): Mage_Core_Block_Template->fetchView(’adminhtml\defau...’)
#6 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(193): Mage_Core_Block_Template->renderView()
#7 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Abstract.php(643): Mage_Core_Block_Template->_toHtml()
#8 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Abstract.php(503): Mage_Core_Block_Abstract->toHtml()
#9 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Abstract.php(454): Mage_Core_Block_Abstract->_getChildHtml(’shipment_tracki...’, true)
#10 C:\wamp\www\magento\app\design\adminhtml\default\default\template\sales\order\shipment\create\form.phtml(68): Mage_Core_Block_Abstract->getChildHtml(’shipment_tracki...’)
#11 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(144): include(’C:\wamp\www\mag...’)
#12 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(176): Mage_Core_Block_Template->fetchView(’adminhtml\defau...’)
#13 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(193): Mage_Core_Block_Template->renderView()
#14 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Abstract.php(643): Mage_Core_Block_Template->_toHtml()
#15 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Abstract.php(503): Mage_Core_Block_Abstract->toHtml()
#16 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Abstract.php(454): Mage_Core_Block_Abstract->_getChildHtml(’form’, true)
#17 C:\wamp\www\magento\app\code\core\Mage\Adminhtml\Block\Widget\Form\Container.php(126): Mage_Core_Block_Abstract->getChildHtml(’form’)
#18 C:\wamp\www\magento\app\design\adminhtml\default\default\template\widget\form\container.phtml(37): Mage_Adminhtml_Block_Widget_Form_Container->getFormHtml()
#19 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(144): include(’C:\wamp\www\mag...’)
#20 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(176): Mage_Core_Block_Template->fetchView(’adminhtml\defau...’)
#21 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(193): Mage_Core_Block_Template->renderView()
#22 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Abstract.php(643): Mage_Core_Block_Template->_toHtml()
#23 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Text\List.php(43): Mage_Core_Block_Abstract->toHtml()
#24 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Abstract.php(643): Mage_Core_Block_Text_List->_toHtml()
#25 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Abstract.php(503): Mage_Core_Block_Abstract->toHtml()
#26 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Abstract.php(454): Mage_Core_Block_Abstract->_getChildHtml(’content’, true)
#27 C:\wamp\www\magento\app\design\adminhtml\default\default\template\page.phtml(73): Mage_Core_Block_Abstract->getChildHtml(’content’)
#28 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(144): include(’C:\wamp\www\mag...’)
#29 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(176): Mage_Core_Block_Template->fetchView(’adminhtml\defau...’)
#30 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Template.php(193): Mage_Core_Block_Template->renderView()
#31 C:\wamp\www\magento\app\code\core\Mage\Core\Block\Abstract.php(643): Mage_Core_Block_Template->_toHtml()
#32 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Layout.php(525): Mage_Core_Block_Abstract->toHtml()
#33 C:\wamp\www\magento\app\code\core\Mage\Core\Controller\Varien\Action.php(339): Mage_Core_Model_Layout->getOutput()
#34 C:\wamp\www\magento\app\code\core\Mage\Adminhtml\controllers\Sales\Order\ShipmentController.php(168): Mage_Core_Controller_Varien_Action->renderLayout()
#35 C:\wamp\www\magento\app\code\core\Mage\Core\Controller\Varien\Action.php(367): Mage_Adminhtml_Sales_Order_ShipmentController->newAction()
#36 C:\wamp\www\magento\app\code\core\Mage\Core\Controller\Varien\Router\Admin.php(143): Mage_Core_Controller_Varien_Action->dispatch(’new’)
#37 C:\wamp\www\magento\app\code\core\Mage\Core\Controller\Varien\Front.php(158): Mage_Core_Controller_Varien_Router_Admin->match(Object(Mage_Core_Controller_Request_Http))
#38 C:\wamp\www\magento\app\Mage.php(457): Mage_Core_Controller_Varien_Front->dispatch()
#39 C:\wamp\www\magento\index.php(52): Mage::run()
#40 {main}

Io ho eliminato tutti i file relativi a quel modulo ma lo stesso mi esce l’errore.Cosa è successo???

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrecord
Guru
 
Avatar
Total Posts:  461
Joined:  2008-06-01
 

per caso lo hai rimosso senza prima disabilitarlo?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Xeon
Jr. Member
 
Total Posts:  27
Joined:  2009-02-25
 

ora che ci penso si!!è un problema....dimmi che almeno si può risolvere!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Xeon
Jr. Member
 
Total Posts:  27
Joined:  2009-02-25
 

Nessuno sa come risolvere?

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrecord
Guru
 
Avatar
Total Posts:  461
Joined:  2008-06-01
 

probabilmente, visto che è rimasto abilitato, magento si aspetta di trovarlo. Se hai modo prova a reinstallarlo, disabilitarlo e poi segalo di nuovo

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top