Magento Forum

probleme installation version 0.8.16100 sur wampserver
 
sidunis
Jr. Member
 
Total Posts:  3
Joined:  2008-02-15
 

Bonjour à tous,

Je suis en test en local sur wampserver 2.0 / Apache 2.2.6 / PHP 5.2.5 / MySQL 5.0.45.

Je rencontre donc un problème lors de l’installation des tables et plus précisément au niveau de la table “design_change” dans laquelle l’installeur insère des tableaux du type :

[12] => Array
                (
                    
[file] => C:\wamp\www\magento\index.php
                    [line] 
=> 28
                    [function] 
=> run
                    [class] 
=> Mage
                    [type] 
=> ::
                    
[args] => Array
                        (
                            
[0] => base
                        
)

                )

suite à ce tableau [12] il m’affiche l’erreur suivante :

[errorInfo] => Array
        (
            
[0] => HY000
            [1] 
=> 2014
            [2] 
=> Cannot execute queries while other unbuffered queries are active.  Consider using PDOStatement::fetchAll().  Alternatively, if your code is only ever going to run against mysqlyou may enable query buffering by setting the PDO::MYSQL_ATTR_USE_BUFFERED_QUERY attribute.
        )

)

exception 'Mage_Core_Exception' with message 'Error in file: "C:\wamp\www\magento\app\code\core\Mage\Core\sql\core_setup\mysql4-install-0.7.0.php" - SQLSTATE[HY000]: General error: 2014 Cannot execute queries while other unbuffered queries are active.  Consider using PDOStatement::fetchAll().  Alternatively, if your code is only ever going to run against mysql, you may enable query buffering by setting the PDO::MYSQL_ATTR_USE_BUFFERED_QUERY attribute.' in C:\wamp\www\magento\app\Mage.php:338
Stack trace
:
#0 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(260): Mage::exception('Mage_Core', 'Error in file: ...')
#1 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(139): Mage_Core_Model_Resource_Setup->_modifyResourceDb('install', '', '0.7.5')
#2 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(126): Mage_Core_Model_Resource_Setup->_installResourceDb('0.7.5')
#3 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(100): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Config.php(181): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 C:\wamp\www\magento\app\code\core\Mage\Core\Model\App.php(174): Mage_Core_Model_Config->init(NULL)
#6 C:\wamp\www\magento\app\Mage.php(367): Mage_Core_Model_App->init('base', NULL)
#7 C:\wamp\www\magento\app\Mage.php(387): Mage::app('base', NULL)
#8 C:\wamp\www\magento\index.php(28): Mage::run('base')
#9 {main}

une idée ??? ....

 
Magento Community Magento Community
Magento Community
Magento Community
 
sidunis
Jr. Member
 
Total Posts:  3
Joined:  2008-02-15
 

ok!

Cette première étape a été franchie en installant les “magento_sample_data” présentent sur la page de download de Magento dernière version ...

... mais ça ne résout apparemment pas mon problème de “buffer” puisque le message d’après est du même acabit :

exception 'Mage_Core_Exception' with message 'Error in file: "C:\wamp\www\magento\app\code\core\Mage\Sales\sql\sales_setup\mysql4-upgrade-0.8.6-0.8.7.php" - SQLSTATE[HY000]: General error: 2014 Cannot execute queries while other unbuffered queries are active.  Consider using PDOStatement::fetchAll().  Alternatively, if your code is only ever going to run against mysql, you may enable query buffering by setting the PDO::MYSQL_ATTR_USE_BUFFERED_QUERY attribute.' in C:\wamp\www\magento\app\Mage.php:338
Stack trace
:
#0 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(260): Mage::exception('Mage_Core', 'Error in file: ...')
#1 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(151): Mage_Core_Model_Resource_Setup->_modifyResourceDb('upgrade', '0.8.6', '0.8.7')
#2 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(117): Mage_Core_Model_Resource_Setup->_upgradeResourceDb('0.8.6', '0.8.7')
#3 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(100): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 C:\wamp\www\magento\app\code\core\Mage\Core\Model\Config.php(181): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 C:\wamp\www\magento\app\code\core\Mage\Core\Model\App.php(174): Mage_Core_Model_Config->init(NULL)
#6 C:\wamp\www\magento\app\Mage.php(367): Mage_Core_Model_App->init('base', NULL)
#7 C:\wamp\www\magento\app\Mage.php(387): Mage::app('base', NULL)
#8 C:\wamp\www\magento\index.php(28): Mage::run('base')
#9 {main}

une idée ? .....

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top