Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

I just wanna go live after 3 months
 
Chris Nudd
Jr. Member
 
Total Posts:  28
Joined:  2008-05-17
 

I’m not the kind of person that asks for help too often, but I am spinning my wheels. I have spent hundreds of hours trying to import categories, manufacturers, products. Converting data from multiple distributors, learning the attribute codes, changing callouts with javascripts. I’m a very tech savvy businessman but not a developer. In spite of my shortcomings, I have managed to get everything in my database after months of work.

About three weeks ago, I tried deleting a store and have had nothing but dead ends. I keep trying to update thinking its going to help some of my issues, but the last one I did via simple scripts gave me this error:

Error in file: “/home1/posdirec/public_html/store/app/code/core/Mage/CatalogInventory/sql/cataloginventory_setup/mysql4-upgrade-0.7.4-0.7.5.php” - SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘cataloginventory_stock_status’ already exists
Trace:
#0 /home1/posdirec/public_html/store/app/code/core/Mage/Core/Model/Resource/Setup.php(292): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /home1/posdirec/public_html/store/app/code/core/Mage/Core/Model/Resource/Setup.php(179): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘0.7.4’, ‘0.7.5’)
#2 /home1/posdirec/public_html/store/app/code/core/Mage/Core/Model/Resource/Setup.php(146): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(’0.7.4’, ‘0.7.5’)
#3 /home1/posdirec/public_html/store/app/code/core/Mage/Core/Model/Resource/Setup.php(121): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home1/posdirec/public_html/store/app/code/core/Mage/Core/Model/Config.php(214): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home1/posdirec/public_html/store/app/code/core/Mage/Core/Model/App.php(242): Mage_Core_Model_Config->init(Array)
#6 /home1/posdirec/public_html/store/app/Mage.php(432): Mage_Core_Model_App->init(’’, ‘store’, Array)
#7 /home1/posdirec/public_html/store/app/Mage.php(453): Mage::app(’’, ‘store’, Array)
#8 /home1/posdirec/public_html/store/index.php(52): Mage::run(’’)
#9 {main}

I tried updating via connect and things just get worse because I can’t downgrade easily.

I am currently running 1.2.2 according to connect but admin still says 1.2.0.3.

I have over 130 categories and 30,000 products, my site is up but I cannot change product visibility or use the layered navigation. I am fine with totally disabling the layered navigation to go live. I don’t know if it is the number of products or what, but trying to change attributes in admin is useless. I think I need to totally reindex, but can’t kill my layered navigation indices. I know there is a bug report for large product lists.

My immediate wish is to have my site reflect the status of my inventory. I did a sql query changing the visibility on 24,000 items to “Search” only and the 6,000 with photos to “Catalog, Search”. But everything is showing. I go to update attributes in admin and try changing everything to “nowhere” and everything still shows up. I have deleted caches, updated search indexes. I’m at a loss. I’m tired and need help.

Thanks,
Chris

www.posdirect.com/store is the magento site. I’ll be glad to give any info needed to help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
DirectLowVoltage
Jr. Member
 
Total Posts:  30
Joined:  2009-02-19
 

http://www.magentocommerce.com/boards/viewthread/30703/

Read that thread all the way through before you start playing…

After you get to the next error.. for other tables that exist… just reply

 
Magento Community Magento Community
Magento Community
Magento Community
 
Carumba
Jr. Member
 
Total Posts:  18
Joined:  2009-02-27
California
 

The site seems to be pretty slow too, taking over 10 seconds to load…

http://tools.pingdom.com/?url=http://www.posdirect.com/store/&treeview;=0&column;=objectIDℴ=1&type;=0&save;=true

 
Magento Community Magento Community
Magento Community
Magento Community
 
aspott
Jr. Member
 
Total Posts:  8
Joined:  2008-11-05
 

Try opening up:

home1/posdirec/public_html/store/app/code/core/Mage/CatalogInventory/sql/cataloginventory_setup/mysql4-upgrade-0.7.4-0.7.5.php

and comment out everything.

It worked for me. Hopefully your store comes up. Look in sql and make sure you have 213 tables. If you do, you are probably good. You may have a lot of items displaying as out of stock, I did. Once you get into your working admin, go to System > Cache Management and hit Inventoy Stock Status REFRESH. That should fix stock issues and it will rebuild the catalog stock status sql table.

As always, you should backup your full install before trying stuff. In this case, I would make sure you do a SQL backup (and store a local copy) at the very least - sounds like you have been working hard on your database.

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
Appmerce
Guru
 
Avatar
Total Posts:  376
Joined:  2008-05-13
Amsterdam, The Netherlands
 

For the solution you must also make sure that all your tables are InnoDB...!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top