Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problem mit Magento Connect bei lokaler Installation mit Xampp
 
knoxx81
Jr. Member
 
Total Posts:  1
Joined:  2009-02-15
 

Hallo Communitiy,

ich bin langsam wirklich am verzweifeln!!! Ich habe auf meinem Mac Xampp installiert und anschließend Magento. Wenn ich jetzt mit Hilfe des Magento Connect Manager eine Erweiterung installieren möchte bekomme ich sofort einen Internal Server Error. In der error_log steht dazu folgendes:

[Mon Mar 02 20:32:52 2009] [alert] [client 192.168.2.33] /Applications/xampp/xamppfiles/htdocs/xampp/downloader/.htaccess: RemoveOutputFilter not allowed here, referer: http://192.168.2.33/xampp/index.php/admind/dashboard/

Ich habe zahlreiche Internetforen durchstöbert und so wie es aussieht ist das Problem anscheinend bei den Berechtigungen zu suchen. Ich habe bereits die Berechtigungen der Verzeichnisse var; media; media/downloadable; media/import; app/etc auf 777 gesetzt. hat aber nichts gebracht.

Unter http://www.magentocommerce.com/boards/viewthread/24455/ habe ich folgendes gefunden:

All files need to be set to 644 and all directories to 755.
Other than that, the following needs to be set to 777 (unless your server is suPHP/suEXEC enabled):-
app/etc , var, and media

Kann das eine Lösung für mein Problem sein? Wenn ja, wie kann ich die Rechte vergeben? ich werde ja nicht für jede datei und jedes verzeichnis einzeln rechte vergeben müssen, oder?

mit filezilla geht das ganz einfach, wenn der Shop auf nem Webserver liegen würde, lokal geht das irgendwie nicht. ich hab auch schon gelesen, dass man xampp mit filezilla verwalten kann, wenn ja wie geht das?

Es wäre echt super, wenn mir der ein oder andere behilflich sein könnte.

greetz

 
Magento Community Magento Community
Magento Community
Magento Community
 
mfrmuc
Jr. Member
 
Total Posts:  3
Joined:  2009-04-02
Munich, Germany
 

nur so ne idee, aber probier doch mal im terminal den befehl chmod aus. der steuert die verzeichnis-schreibrechte… achte darauf, dass auch die subdirectories entsprechend versehen werden (glaube das war mit nem -R hinten dran, aber da gibt dir die hilfe sicherlich mehr infos).

Generell gilt: Ich hab mir zuerst auch gedacht, dass ich das ich den Shop testhalber mal in einer XAMPP Umgebung laufen lasse, bevor ich den Aufwand mit einem eigenen Server angehe. Dieser Ansatz hat sich sehr schnell als “dumme Idee” identifiziert. XAMPP ist - zumindest auf dem Windows-Rechner, den ich hier im Büro habe, deutlich zu langsam, so dass ich dann doch einen Server freigeräumt habe. Auf dem (HP Proliant, 2x XEON CPU, 2GB RAM) läuft es jetzt mit ner annehmbaren Geschwindigkeit. Shared Server oder gar virtuelle Umgebungen wie XAMPP sind mit Magento sehr schnell sehr überfordert…

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top