Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Error Upgrading to 1.2.1.1
 
chanchel
Member
 
Total Posts:  43
Joined:  2008-09-04
 

I attempted to upgrade from 1.2.0 to 1.2.1.1 through Magento Connect and this is the error I receive.  I can no longer access the admin panel or my website:

Error in file: “/home/partenet/public_html/app/code/core/Mage/CatalogInventory/sql/cataloginventory_setup/mysql4-upgrade-0.7.4-0.7.5.php” - SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘cataloginventory_stock_status’ already exists
Trace:
#0 /home/partenet/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(292): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /home/partenet/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(179): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘0.7.4’, ‘0.7.5’)
#2 /home/partenet/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(146): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(’0.7.4’, ‘0.7.5’)
#3 /home/partenet/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(121): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/partenet/public_html/app/code/core/Mage/Core/Model/Config.php(214): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/partenet/public_html/app/code/core/Mage/Core/Model/App.php(242): Mage_Core_Model_Config->init(Array)
#6 /home/partenet/public_html/app/Mage.php(432): Mage_Core_Model_App->init(’’, ‘store’, Array)
#7 /home/partenet/public_html/app/Mage.php(453): Mage::app(’’, ‘store’, Array)
#8 /home/partenet/public_html/index.php(52): Mage::run()
#9 {main}

Thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
esa100
Jr. Member
 
Avatar
Total Posts:  22
Joined:  2008-11-06
 

I have the same problem.  It comes from the wrong db-engine…

Welcome to the boat of currently unfixable issues:  check this thread:

http://www.magentocommerce.com/boards/viewthread/26356/P0/

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top