Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problem PLACE ORDER
 
francedev
Jr. Member
 
Total Posts:  2
Joined:  2008-08-26
 

When I click place order we have this bug.

2009-03-01T18:08:42+00:00 ERR (3):
#0 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Block/Template.php(144): mageCoreErrorHandler(2, ‘Mage_Core_Block...’, ‘/homez.47/metau...’, 144, Array)
#1 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Block/Template.php(144): Mage_Core_Block_Template::fetchView()
#2 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Block/Template.php(176): Mage_Core_Block_Template->fetchView(’frontend/Neurol...’)
#3 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Block/Template.php(193): Mage_Core_Block_Template->renderView()
#4 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Block/Abstract.php(643): Mage_Core_Block_Template->_toHtml()
#5 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Model/Layout.php(525): Mage_Core_Block_Abstract->toHtml()
#6 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Model/Email/Template/Filter.php(111): Mage_Core_Model_Layout->getOutput()
#7 [internal function]: Mage_Core_Model_Email_Template_Filter->layoutDirective(Array)
#8 /homez.47/xxx/www/xxxxxx/lib/Varien/Filter/Template.php(128): call_user_func(Array, Array)
#9 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Model/Email/Template.php(282): Varien_Filter_Template->filter(’??<style type=”...’)
#10 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Model/Email/Template.php(344): Mage_Core_Model_Email_Template->getProcessedTemplate(Array, true)
#11 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Model/Email/Template.php(405): Mage_Core_Model_Email_Template->send(’xxx@xx..’, ‘xxx xxx’, Array)
#12 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Sales/Model/Order.php(636): Mage_Core_Model_Email_Template->sendTransactional(’sales_email_ord...’, ‘sales’, ‘xxx@xxxx...’, ‘xx xxx’, Array)
#13 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Checkout/Model/Type/Onepage.php(567): Mage_Sales_Model_Order->sendNewOrderEmail()
#14 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Checkout/controllers/OnepageController.php(385): Mage_Checkout_Model_Type_Onepage->saveOrder()
#15 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Controller/Varien/Action.php(367): Mage_Checkout_OnepageController->saveOrderAction()
#16 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(163): Mage_Core_Controller_Varien_Action->dispatch(’saveOrder’)
#17 /homez.47/xxx/www/xxxxxx/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#18 /homez.47/xxx/www/xxxxxx/app/Mage.php(457): Mage_Core_Controller_Varien_Front->dispatch()
#19 /homez.47/xxx/www/xxxxxx/index.php(52): Mage::run()
#20 {main}

 
Magento Community Magento Community
Magento Community
Magento Community
 
bstdevelopment
Member
 
Total Posts:  48
Joined:  2008-04-14
 

I am pretty new the magento but it appears it’s an xml error in one of your template files. I’ve got a similar error but with a new payment module.

eclipse for php ide has a nice way finding the xml files that are not valid - maybe it’s an unclosed tag for instance

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top