Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Installation issues
 
krystalvixxen
Newbie
 
Total Posts:  0
Joined:  2013-04-11
 

I’ve been trying for over 5 hours to get Magento to install - but it won’t!

I’m on Linux hosting with no SSH access, PHP 5.3 - All I ever get is “file permission error” whenever I try to load the page - I’ve tried every setting possible, but it still won’t install. At one point it did go to the initial screen, but when I pressed continue I had the same error again,

I tried redownloading, reuploading, different permissions, but nothing!

If I can’t sort this out soon I might as well spend my money on an e-commerce solution I can actually use!

What am I missing here?

****UPDATE****

After hours of trawling google and the forums it seems it is a Heart Internet permissions problem - changing the php.ini to php5.ini and putting this in the .htaccess file seems to work....

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php5-cgi

#Action php5-cgi /cgi-bin/php-cgi
#AddHandler php5-cgi .php

#############################
## For heart internet
SetEnv DEFAULT_PHP_VERSION 5

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

php_value memory_limit 32M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## enable php short tags for templates

php_flag short_open_tag on

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8
Order allow,deny
Allow from all

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top