Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Can’t view product pages - 404 errors
 
Mark Robinson
Member
 
Total Posts:  40
Joined:  2008-04-08
 

Hi

So I’m in the process of upgrading a site from 1.1.6 to 1.2.1 and also I’m adding a store with a new view. Everything was working fine after updating so I started in to making the new template for the new store and next thing I know I can’t access the product view anymore. I remember this worked after upgrading and I think just after creating the new store. The product links redirect to 404 page not found with my new store and weirdly redirect to the homepage with my old store view. I’ve tried refreshing the cache and refreshing rewrites (even deleting the rewrites and turning rewrites off in configuration but no difference. I then tried creating a new store (under the same site) and using the default template but that hasn’t worked.

Any ideas how to narrow this down? I don’t want to have to start over if possible.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mark Robinson
Member
 
Total Posts:  40
Joined:  2008-04-08
 

So I solved my own problem in time. I had done 2 things wrong: I had moved the product view.phtml page out of the default template instead of copying it and had forgotten to set the permissions correctly. The permissions missing meant I didn’t see the report telling me I was missing a file. So don’t forget to do:

chmod -R 777 media
chmod -R 777 var
chmod 775 pear
chmod 777 app/etc

Mark

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top