Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Strange Url rewrite behavior
 
mzentrale1
Guru
 
Total Posts:  731
Joined:  2007-12-06
Stuttgart, Germany
 

Hi people,

i have a strange behavior within url rewrite of magento catalog, all cms pages/rewrites work fine, also cart, account and checkout works fine. Only my cataglog/category rewrites doesnt work and www.foo.de/admin also doesnt work - ill be redirected to 404 folder of amgento! I uploaded my local installation and importet database to live system. If i try www.foo.de/index.php/admin iam also redirected to 404 folder (www.foo.de/404) :(

Here is my .htaccess:

<IfModule mod_rewrite.c>

############################################
## enable rewrites    
    
RewriteEngine On

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/
    
RewriteRule ^minify/([^/]+)(/.*\.js)$ lib/minify/m.php?f=$2&$
    RewriteRule 
^index.php/minify/([^/]+)(/.*\.js)$ lib/minify/m.php?f=$2&$
    RewriteRule 
^minify/([^/]+)(/.*\.css)$ lib/minify/m.php?f=$2&$
    RewriteRule 
^index.php/minify/([^/]+)(/.*\.css)$ lib/minify/m.php?f=$2&$1

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>

Also the minify rewrites works. Not the catalog, iam redirected to magentos 404 folder. any idea?

cheers

Stefan

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top