Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Wrong version of php detected if I enable SSL
 
PCGamesPlus
Sr. Member
 
Avatar
Total Posts:  166
Joined:  2008-01-03
Sacramento, CA
 

I am using Magento ver. 0.7.15480 on a 1 and 1 shared server. I have added the necessary lines to the .htaccess file and got things going no problem. I have my own SSL cert purchased through 1 and 1 from geotrust when I first got the account a couple of months ago. The cert is set up OK as far as I can tell. I did a fresh reinstall today and tried something a little different this time. I enabled the SSL for the site. The front end is OK. The admin log in back end and the customer log in is hosed. whenever it has an “https:” in the url I get the “wrong php version” error message. Remember I had already added the proper line to the .htaccess file, and it installed so I know it’s the right version. Anyway I did another fresh install without enabling the SSL and the frontend and back end both work fine. I can still make it error by adding an “s” to the “http:” with the SSL disabled at install.  Anyone know the answer to this one?

Update---- I installed ver. 0.8.16100, it still does the same thing.  Help?

 
Magento Community Magento Community
Magento Community
Magento Community
 
PCGamesPlus
Sr. Member
 
Avatar
Total Posts:  166
Joined:  2008-01-03
Sacramento, CA
 

I got my problem solved. What I had to do was change the .htaccess file.

There is a special line in the default .htaccess for people that use 1and1 hosting.

I changed it from

AddType x-mapp-php5 .php

To

AddHandler x-mapp-php5 .php

Now Admin Login and Customer Login works great.

Funny thing though that the way I had it was per 1and1’s FAQ’s and also from what I had read in these forums.

Roy, you might want to change that line for people using SSL with 1and1 hosting in the .htaccess file.

Thanks to anyone that took the time to look into it. smile

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top