Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Store won’t recognize new catagories
 
ScottSt
Member
 
Total Posts:  52
Joined:  2009-02-06
 

I’m testing a new design we have and I have a problem- Magento won’t recognize new product catagories. My product tree currently looks like this:

Root Catalog
-Catalog (Used to display our categories)
-Peanut Butter Gear*
-Hats*
-Shirts*
-Peanut Butter Pantry (1 item)
-Gift Assortments (1 item)

The Catalog page recognizes and displays the Peanut Butter Gear items just fine, but won’t display anything from PB Pantry or Gift Assortments OR display them under the “Category” listing. Going to pbpantry.html or whatever the root page is does just the same- Refuses to recognize the items associated with those catagories.I’ve associated all my items correctly- What am I missing?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ScottSt
Member
 
Total Posts:  52
Joined:  2009-02-06
 

Any ideas? I’ve spent all day playing with this- I can’t seem to get Magento to recognize my new categories or my new items. They’re in Admin, but they don’t appear on the site

 
Magento Community Magento Community
Magento Community
Magento Community
 
ScottSt
Member
 
Total Posts:  52
Joined:  2009-02-06
 

FYI, here’s a screenshot ofthe main category:

I’ve done a Cache refresh, main cache is off. Just checked my store management, everything is as it should be. That first category (PB&co;Gear) is fine. Everything else is not. Thoughts?

Image Attachments
magentocatprob.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
ScottSt
Member
 
Total Posts:  52
Joined:  2009-02-06
 

Now when I’m assigning products to categories, they’re not being listed when I check under the categories--->products menu.

It’s pikcing up on any changes to the one category it recognizes, but still refuses to add any others.

Anyone have any thoughts/leads? I’ve literally been poking at this for 4 or 5 hours with no results. I don’t mind doing this during development, but if there’s not a clear fix here, I’m afraid to use Magento as a Live product.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ScottSt
Member
 
Total Posts:  52
Joined:  2009-02-06
 

Pretend I never made this post and that I am not a colossal idiot.

I had added my items to “Root Catalog” but not not to “Catalog”. Hence, they failed to show up. Ugh.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top