Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

IE 7 Error: Object doesn’t support this property or method. 
 
scoreboard
Jr. Member
 
Total Posts:  13
Joined:  2008-06-10
 

*UPDATE*

We have figured out the issue thanks to the Magento Support people.

 
Magento Community Magento Community
Magento Community
Magento Community
 
AllynWA
Jr. Member
 
Total Posts:  28
Joined:  2008-12-02
Allyn, WA
 

Hi…
Could you post what you learned here? I am getting the same error in IE7, and Google Chrome just fails with no warning.

Specifically, when I go to Magento Connect and try to download (or manage) extensions, this error started showing up today. Clicking “Install” throws the error in IE7 and Google appears to ignore it but does nothing.

Thanks greatly,
Fred

 
Magento Community Magento Community
Magento Community
Magento Community
 
scoreboard
Jr. Member
 
Total Posts:  13
Joined:  2008-06-10
 

Our error was only on the front end and it involved some code from the old Magento default theme. 

The file:

app\design\frontend\THEME\THEME\template\tag\list.php on line 43

Instead of :

name="tagName"”

Change that to:

name="productTagName"

That fixed it for us.  For you I would assume it is something very similar.  Most likely it’s something in the theme design that is causing it.  Did you create your theme based on the default theme?

 
Magento Community Magento Community
Magento Community
Magento Community
 
AllynWA
Jr. Member
 
Total Posts:  28
Joined:  2008-12-02
Allyn, WA
 

Thank you, no that value is fine in my installation. This is a brand-new fresh install of version 1.2.1.2 with the default theme.

I think I am dealing with a plug-in issue, as this started as soon as I installed the cybersource plugin. Line 180 in the Magento Connect screen starts failing and throwing the “Object doesn’t support property or method” error while looping here:

$$(’#pear_packages_’+0+’ select’).each(function(el){el.value=’’});

Back to the drawing board. Thanks again.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top