Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Mehrere Storeviews /Verkaufsförderung geht nichts
 
ulise
Jr. Member
 
Total Posts:  12
Joined:  2009-02-23
 

Hallo,

wir haben auf einem neuen server magento 1.2.1 installiert und alles geht, bis auf :

wenn wir einen weiteren Storeview anlegen, der selbst deaktiviert ist, geht die Verkaufsförderung gar nicht mehr!! Fehlermeldung:

There has been an error processing your request.

Notice: Trying to get property of non-object in /home/www/web3/html/app/code/core/Mage/Adminhtml/Model/System/Config/Source/Website.php on line 37
Trace:
#0 /home/www/web3/html/app/code/core/Mage/Adminhtml/Model/System/Config/Source/Website.php(37): mageCoreErrorHandler(8, ‘Trying to get p...’, ‘/home/www/web3/...’, 37, Array)
#1 /home/www/web3/html/app/code/core/Mage/Adminhtml/Block/Promo/Quote/Edit/Tab/Main.php(91): Mage_Adminhtml_Model_System_Config_Source_Website->toOptionArray()
#2 /home/www/web3/html/app/code/core/Mage/Adminhtml/Block/Widget/Form.php(139): Mage_Adminhtml_Block_Promo_Quote_Edit_Tab_Main->_prepareForm()
#3 /home/www/web3/html/app/code/core/Mage/Core/Block/Abstract.php(642): Mage_Adminhtml_Block_Widget_Form->_beforeToHtml()
#4 /home/www/web3/html/app/code/core/Mage/Adminhtml/Block/Promo/Quote/Edit/Tabs.php(50): Mage_Core_Block_Abstract->toHtml()
#5 /home/www/web3/html/app/code/core/Mage/Core/Block/Abstract.php(642): Mage_Adminhtml_Block_Promo_Quote_Edit_Tabs->_beforeToHtml()
#6 /home/www/web3/html/app/code/core/Mage/Core/Block/Text/List.php(43): Mage_Core_Block_Abstract->toHtml()
#7 /home/www/web3/html/app/code/core/Mage/Core/Block/Abstract.php(643): Mage_Core_Block_Text_List->_toHtml()
#8 /home/www/web3/html/app/code/core/Mage/Core/Block/Abstract.php(503): Mage_Core_Block_Abstract->toHtml()
#9 /home/www/web3/html/app/code/core/Mage/Core/Block/Abstract.php(454): Mage_Core_Block_Abstract->_getChildHtml(’left’, true)
#10 /home/www/web3/html/app/design/adminhtml/default/default/template/page.phtml(57): Mage_Core_Block_Abstract->getChildHtml(’left’)
#11 /home/www/web3/html/app/code/core/Mage/Core/Block/Template.php(144): include(’/home/www/web3/...’)
#12 /home/www/web3/html/app/code/core/Mage/Core/Block/Template.php(176): Mage_Core_Block_Template->fetchView(’adminhtml/defau...’)
#13 /home/www/web3/html/app/code/core/Mage/Core/Block/Template.php(193): Mage_Core_Block_Template->renderView()
#14 /home/www/web3/html/app/code/core/Mage/Core/Block/Abstract.php(643): Mage_Core_Block_Template->_toHtml()
#15 /home/www/web3/html/app/code/core/Mage/Core/Model/Layout.php(525): Mage_Core_Block_Abstract->toHtml()
#16 /home/www/web3/html/app/code/core/Mage/Core/Controller/Varien/Action.php(339): Mage_Core_Model_Layout->getOutput()
#17 /home/www/web3/html/app/code/core/Mage/Adminhtml/controllers/Promo/QuoteController.php(98): Mage_Core_Controller_Varien_Action->renderLayout()
#18 /home/www/web3/html/app/code/core/Mage/Core/Controller/Varien/Action.php(367): Mage_Adminhtml_Promo_QuoteController->editAction()
#19 /home/www/web3/html/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php(143): Mage_Core_Controller_Varien_Action->dispatch(’edit’)
#20 /home/www/web3/html/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Admin->match(Object(Mage_Core_Controller_Request_Http))
#21 /home/www/web3/html/app/Mage.php(457): Mage_Core_Controller_Varien_Front->dispatch()
#22 /home/www/web3/html/index.php(52): Mage::run()
#23 {main}

Wenn wir den zusätzlichen Storeview löschen geht die Preisregel wieder zu bearbeiten ohne Fehlermeldung.

Was kann hier der Fehler sein?? Serverseitig?? .htaccess??

Wir wissen nicht mehr weiter

Danke

Gruss

Uli

 
Magento Community Magento Community
Magento Community
Magento Community
 
thE_iNviNciblE
Sr. Member
 
Avatar
Total Posts:  220
Joined:  2008-01-09
Oldenburg
 

schonmal versucht die regel zu löschen und neu anzulegen ?

ich habe persönlich diesen fehler noch nie gesehen… kann es sein das der “base code” bei der Storeverwaltung geändert wurde?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top