Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Magento is wrong
 
bayers064
Sr. Member
 
Total Posts:  105
Joined:  2013-01-04
 

The time on my magento store is 8 hours ahead of the time i set it to.

How do i fix this

Community 1.7

Image Attachments
timestamp.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
redstage
Sr. Member
 
Avatar
Total Posts:  173
Joined:  2009-12-04
Hoboken, NJ
 

Try checking out the setting in System -> Configuration :: Locale Options.  In there, you can set the timezone for Magento.

Otherwise, it might be a server setting that isn’t configured correctly.

Hope that helps!

Anthony
Redstage Extension Store

 
Magento Community Magento Community
Magento Community
Magento Community
 
bayers064
Sr. Member
 
Total Posts:  105
Joined:  2013-01-04
 

That is set to our local time Pacific Standard Time, yet the clock is 8 hours ahead.

 
Magento Community Magento Community
Magento Community
Magento Community
 
redstage
Sr. Member
 
Avatar
Total Posts:  173
Joined:  2009-12-04
Hoboken, NJ
 

That’s a strange one - It\’s changing the time to GMT/UTC time. 

I found this that might help, from another thread:

BigCityShelts - 12 November 2009 11:19 AM

I spent hours with this problem.  I found a number of solutions in the forums, none of which worked for me.  Eventually, this was the process I used to solve the issue.  I searched for occurrences of \’UTC\’, Magento\’s default timezone:

grep -R \'UTC\' .

from the app/ directory.  I found a line in Mage.php that was causing it:

date_default_timezone_set('UTC');

and changed it to my appropriate timezone.

All the fancy structure in Locale.php, the backend option, and this one line was overriding it all!  Took me hours to find but it solved the problem.

Hope it works!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top