Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden
 
Alejandro
Jr. Member
 
Total Posts:  6
Joined:  2007-08-31
 

I am getting the error in my error log:

[Fri Aug 31 11:32:59 2007] [error] [client 166.70.57.233] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /home/magento/
[Fri Aug 31 11:33:13 2007] [error] [client 166.70.57.233] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /home/magento/index.php

In my vhost I have the following:

<VirtualHost *:80>
ServerName magentotest.com
ServerAlias http://www.magentotest.com
DocumentRoot /home/magento/
ErrorLog logs/magentotest.com-error_log
CustomLog logs/magentotest.com-access_log combined
Options +FollowSymLinks
</VirtualHost>

I also set the correct permissions:
chmod -R 755 /home/magento

I have hard coded magentotest.com to point to the correct ip on my local box.

What am I doing wrong here?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Alejandro
Jr. Member
 
Total Posts:  6
Joined:  2007-08-31
 

Never mind, I got it working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lenny2
Sr. Member
 
Total Posts:  171
Joined:  2008-05-21
München
 

great - and how?
you want help from the community but don’t want share your experiences?

 
Magento Community Magento Community
Magento Community
Magento Community
 
dyslexik
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2009-01-19
 

I had the same problem and found that

http://corz.org/serv/tricks/htaccess2.php

Although highly unlikely, your host may have +FollowSymLinks enabled at the root level, yet disallow its addition in .htaccess; in which case, adding +FollowSymLinks will break your setup (probably a 500 error), so just remove it, and your rules should work fine.

I just commented the

Options +Followsymlinks

line in magento .htaccess file and no more error 500 message.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top