Magento Forum

   
Can’t upload product image
 
spstieng
Member
 
Total Posts:  38
Joined:  2009-02-08
 

After a few tries installing Magento, I’ve finally managed to install it without to much trouble.
I’m running on the latest version (v1.2.1) and I have installed ‘Modern Theme’.
I’ve sett the cataloug permission to 755 for all catalouges.

But I run into a problem - I can’t upload product images.

When I click the ‘Upload Files’ button, a popup “message” is diaplyed.
It looks like a login page, only it’s showing the actual HTML and not the login page.

Why do I get a “login page” here?

I’ve installed Magento on another server (another ISP), and I do not get this problem.

I’ve search the forum, tried different “solution”, but non works.
http://www.magentocommerce.com/boards/viewthread/7009/P180/#t104841

Hmm..... what now?

Image Attachments
magento_upload_err_msg.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
spstieng
Member
 
Total Posts:  38
Joined:  2009-02-08
 

Ok, I don’t remember where I got this from, but this did it for me.

My ISP allows me to have my own php.ini files. Sho I created one and added this to it:

magic_quotes_gpc = off
flag session.auto_start = off
zlib.output_compression = on
suhosin.session.cryptua = off
zend.ze1_compatibility_mode = off
extension=mcrypt.so
extension=pdo.so
extension=pdo_mysql.so
short_open_tag = on
memory_limit = 32M

Now I was able to upload images.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kiatng
Enthusiast
 
Total Posts:  875
Joined:  2008-09-03
Kuala Lumpur, Malaysia
 

Thanks Steven. I had exactly the same problem, my ver is 1.2.1.2. I made the php.ini, put that in the Magento root directory, and the images can be uploaded immediately, just like that.

 
Magento Community Magento Community
Magento Community
Magento Community
 
spunky
Jr. Member
 
Total Posts:  1
Joined:  2009-03-14
 

thankyou spstieng! that worked a treat

for those running cPanel just create a file called php.ini, put the above settings in the file and upload it to your public_html/ directory

 
Magento Community Magento Community
Magento Community
Magento Community
 
justinb
Jr. Member
 
Total Posts:  1
Joined:  2009-03-08
 

Ah!  Thank you so much… I have spent 3 days attempting to fix this, and have tried everything.

The php.ini works perfectly.  I can’t believe how simple the fix was in the end.

 
Magento Community Magento Community
Magento Community
Magento Community
 
thegatner
Jr. Member
 
Total Posts:  21
Joined:  2009-03-19
 

Thanks a lot Spstieng and Spunky. Alot of people can benefit from this, I saw so many posts and couldnt find answer, I am gonna tell them to see this post.

 
Magento Community Magento Community
Magento Community
Magento Community
 
CordiS
Jr. Member
 
Total Posts:  3
Joined:  2008-10-31
 

I have the same problem, but with Firefox 2.0 on Windows. My php.ini contents necessary settings but the alert window with a part of some page code appears to me once I tries to upload images.

 
Magento Community Magento Community
Magento Community
Magento Community
 
DogQuality
Jr. Member
 
Total Posts:  18
Joined:  2009-03-05
 

I have spent the whole day trying to fix this and tried different changes to php.ini and nothing worked until now. Thank you thank you thank you - this worked like a charm! LOL

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yeen
Jr. Member
 
Total Posts:  3
Joined:  2008-09-11
 

suhosin.session.cryptua = off

i try~ just add this option to php.ini, it will work~

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top