Magento Forum

   
magento redirecting full domain name to localhost on fresh install
 
morekitsch
Jr. Member
 
Total Posts:  1
Joined:  2012-10-13
 

Hi,

I’m working with a fresh install of Magento on nginx and php5.3

The install page never comes up it takes my full domin and turn it into localhost

something like this: http://localhost/index.php/install/?SID=elf663odnvn0ci4pv913nvlaq7

for a nginx config I’m using the standard one you find around the net:

server {
#    listen 80 default;
## SSL directives might go here
    
server_name store2.kfm.org;
   
#server_name_in_redirect off;
    
root /usr/local/www/kf/magento2/;

    
location {
        index index
.html index.php## Allow a static html file to be shown first
        
try_files $uri $uri/ @handler## If missing pass the URI to Magento's front handler
        
expires 30d## Assume all files are cachable
    
}

    
## These locations would be hidden by .htaccess normally
    
location ^~ /app/                { deny all}
    location 
^~ /includes/           { deny all}
    location 
^~ /lib/                { deny all}
    location 
^~ /media/downloadable{ deny all}
    location 
^~ /pkginfo/            { deny all}
    location 
^~ /report/config.xml   { deny all}
    location 
^~ /var/                { deny all}

    location 
/var/export## Allow admins only to view export folder
#        auth_basic           "Restricted"; ## Message shown in login window
#        auth_basic_user_file htpasswd; ## See /etc/nginx/htpassword
        
autoindex            on;
    
}

    location  
/\## Disable .htaccess and other hidden files
        
return 404;
    
}

    location 
@handler { ## Magento uses a common front handler
        
rewrite / /index.php;
    
}

    location 
\.php## Forward paths like /js/index.php/x.js to relevant handler
        
rewrite ^(.*.php)/ $1 last;
    
}

    rewrite 
^/minify/([0-9]+)(/.*.(js|css))$ /lib/minify/m.php?f=$2&d;=$1 last;
    
rewrite ^/skin/m/([0-9]+)(/.*.(js|css))$ /lib/minify/m.php?f=$2&d;=$1 last;

    
location /lib/minify{
        allow all
;
    
}

    location 
\.php## Execute PHP scripts
        
if (!-e $request_filename{ rewrite / /index.php last## Catch 404s that try_files miss

        
expires        off## Do not cache dynamic content
        
fastcgi_pass   127.0.0.1:9000;
        
#fastcgi_param  HTTPS $fastcgi_https;
        
fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
        
fastcgi_param  MAGE_RUN_CODE default; ## Store code is defined in administration > Configuration > Manage Stores
        
fastcgi_param  MAGE_RUN_TYPE store;
        include        
fastcgi_params.conf## See /etc/nginx/fastcgi_params
    
}

if I try and change local host to use my domain the text come sup, but all off the JS and CSS files etc are broken because they are being directed to localhost.  This seems like an internal Magento redirect issue, but I can’t find anything that would tell it to use localhost.

Any ideas or investigative notions would be apreciated

 
Magento Community Magento Community
Magento Community
Magento Community
 
Seehausen
Jr. Member
 
Total Posts:  1
Joined:  2013-09-03
 

Any solutions to this problem ... ? grin

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top