Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

pdo_mysql must be loaded, I only have pdo_sqlite + bad request
 
Fidelity
Member
 
Avatar
Total Posts:  49
Joined:  2007-09-20
 

I am having some troubles installing Magento…

Without any workaround I get an error message saying:

PHP Extension “pdo_mysql” must be loaded

During the configuration part of the installation…
When checking the PHP info file it says:

PDO support enabled
PDO drivers sqlite2, sqlite

So no pdo_mysql! How do I get pdo_mysql?

--

If I try to use the php5-cgi workaround I get:
400 Bad Request

I am using PHP 5.2.5 and MYSQL 5.0.45
PHP info

htaccess:

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php5-cgi

# Action php5-cgi ../cgi-bin/php5-cgi
# AddHandler php5-cgi .php



############################################
## this line is specific for 1and1 hosting

# AddType x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

    
php_value memory_limit 32M

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## enable php short tags for templates

    
php_flag short_open_tag on

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder path relative to web root

    
RewriteBase /webwinkel/

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8
Order allow,deny
Allow from all
 
Magento Community Magento Community
Magento Community
Magento Community
 
arkmedia
Jr. Member
 
Total Posts:  3
Joined:  2008-02-07
 

uncomment (#) the top two lines.

from this;

# Action php5-cgi ../cgi-bin/php5-cgi
# AddHandler php5-cgi .php

to this;

Action php5-cgi ../cgi-bin/php5-cgi
AddHandler php5-cgi .php

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fidelity
Member
 
Avatar
Total Posts:  49
Joined:  2007-09-20
 

As you can read I already tried that:

“If I try to use the php5-cgi workaround I get:
400 Bad Request”

 
Magento Community Magento Community
Magento Community
Magento Community
 
arkmedia
Jr. Member
 
Total Posts:  3
Joined:  2008-02-07
 

You may have 2 issues -
1 your main site host needs to be making access to the right version of php with the root htaccess file and
2 your directory in the line of code above “/cgi-bin/php5-cgi “ may be flawed as the hosting companies don’t make the home directory obvious so it may need to be something like “/~websiteaccountname/cgi-bin/php5-cgi”

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fidelity
Member
 
Avatar
Total Posts:  49
Joined:  2007-09-20
 

Hmm I don’t understand fully what you are trying to say…
I don’t have many contact with my host since I have my own Virtual Private Server.

I don’t understand point 1 fully?

Point 2: You mean I should use the full path? So something like: “/home/sites/mywebsite.com/magento/cgi-bin/php5-cgi”?

Maybe all of this is because I have magento installed in a sub directory?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fidelity
Member
 
Avatar
Total Posts:  49
Joined:  2007-09-20
 

Anyone!!??

I have enterd the full path in the htaccess, now I’m getting a 404 not found error when I go to the subdirectory

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fidelity
Member
 
Avatar
Total Posts:  49
Joined:  2007-09-20
 

...

 
Magento Community Magento Community
Magento Community
Magento Community
 
kameko.rouge
Member
 
Total Posts:  58
Joined:  2007-10-11
 

hmm, how about enabling pdo for mysql like the error clearly states.

why bother with your own VPS if you have no idea what you’re doing.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fidelity
Member
 
Avatar
Total Posts:  49
Joined:  2007-09-20
 

I tried! But it didn’t work. Thats the whole problem!

Php info file:
PDO support enabled
PDO drivers sqlite2, sqlite

As you can see I don’t have PDO_mysql enabled. Why? I dont know!

I tried installing it… After installing and following everything like this guy posted:
http://directadmin.com/forum/showpost.php?p=121729&postcount;=4

my apache won’t start anymore… Why? That’s the part where I get stuck. I don’t understand at all!

 
Magento Community Magento Community
Magento Community
Magento Community
 
iblastoff
Sr. Member
 
Total Posts:  252
Joined:  2007-08-31
 

uhh so your apache wont start anymore??? get some help from your host? thats pretty out of scope for anyone here to solve for you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fidelity
Member
 
Avatar
Total Posts:  49
Joined:  2007-09-20
 

I have a VPS. I don’t get any support with that

 
Magento Community Magento Community
Magento Community
Magento Community
 
iblastoff
Sr. Member
 
Total Posts:  252
Joined:  2007-08-31
 

what are you expecting to happen then? you want someone here to fix your server for you?

 
Magento Community Magento Community
Magento Community
Magento Community
 
inspi9100
Jr. Member
 
Total Posts:  2
Joined:  2008-07-14
 

Hello
I had the same problem , but my buddy told to
enable php_pdo.dll i.e, remove the comment line in the php.ini file for the line ;php_pdo.dll

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top