Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

PEAR error when trying to install a package through Magento Connect
 
eduardoSA
Jr. Member
 
Total Posts:  15
Joined:  2009-02-10
 

I’ve been receiving this error ever since I installed Magento. I don’t know how to use channel://pear.php.net/PEAR, and I don’t know what the system means by that. It’s not related to the Settings tab where you can choose stable, beta and alpha, it’s something else. Please help!

Failed to download pear/PEAR within preferred state “stable”, latest release is version , stability “”, use “channel://pear.php.net/PEAR” to install
magento-core/Mage_Pear_Helpers requires package “pear/PEAR” (version >= 1.6.2)
magento-core/Lib_Google_Checkout requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Mage_Core_Modules requires package “magento-core/Lib_Google_Checkout” (version >= 1.2.0, version <= 1.2.2, excluded versions: 1.2.2)
magento-core/Interface_Frontend_Default_Blank requires package “magento-core/Mage_Core_Modules” (version >= 1.2.1, version <= 1.2.2, excluded versions: 1.2.2)
magento-core/Lib_Js_Calendar requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Js_Prototype requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Js_Mage requires package “magento-core/Lib_Js_Prototype” (version >= 1.2.0, version <= 1.2.2, excluded versions: 1.2.2)
magento-core/Lib_ZF requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
magento-core/Lib_Varien requires package “magento-core/Lib_ZF” (version >= 1.7.2.1, version <= 1.7.3, excluded versions: 1.7.3)
magento-core/Lib_ZF_Locale requires package “magento-core/Mage_Pear_Helpers” (version >= 1.0.18800)
Install Errors
No valid packages found
PEAR ERROR: install failed

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

If you have SSH access, try this:

From your Magento root directory, run:

./pear channel-add pear.php.net

Then try to run Magento Connect again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Enthusiast
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

I’ve just started seeing something similar where I am being blocked from pear.php.net when attempting to access it via Magento.

Scenario:

I am running Magento 2.1 on XAMPP 1.6.8 (Windows vista) configuration.

This machine has had Magento running on it many times (rebuild the sandbox every few days). Starting yesterday, however:

1) I browse to pear.php.net , can browse around, download packages ,etc
2) I launch Magento Connect and attempt to download the Modern theme
3) Install fails with this error:

“Connection to `pear.php.net:80’ failed: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.”

4) When I try to browse to pear.php.net it times out.
5) After 10 minutes I can browse to pear.php.net again

Is Magento traffic being blocked by pear.php.net suddenly for some reason?

This is running on a non-firewalled household DSL and repeatable on the Cable Modem. I

Anyone else seeing this?

Any suggestions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Enthusiast
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

Been testing this at various locations (different ISPs and machines) with similar results.

This morning the errors changed to:

Could not download from “http://pear.php.net/get/PEAR-1.7.2.tgz”, cannot download “pear/PEAR” (File http://pear.php.net:80/get/PEAR-1.7.2.tgz not valid (redirected but no location))

 
Magento Community Magento Community
Magento Community
Magento Community
 
winlux
Jr. Member
 
Total Posts:  5
Joined:  2009-02-22
Jenaz (Switzerland)
 

I have a sort of similar problem since yesterday. “pear channel-add pear.php.net” tells me “cannot open pear.php.net” (while I can open pear.php.net in the webbrowser at that machine).

The error from Magento Connect is:
No releases available for package “connect.magentocommerce.com/core/Interface_Frontend_Default_Blank”
Cannot initialize ‘channel://connect.magentocommerce.com/core/Interface_Frontend_Default_Blank’, invalid or missing package file
Install Errors
Package “channel://connect.magentocommerce.com/core/Interface_Frontend_Default_Blank” is not valid
PEAR ERROR: install failed

I geht that error for every package I try.

When I installed magento a week ago I could install language packages without any problem. The Linux installation didn’t change since then. It’s installed at an Arch Linux placed in a VirtualPC 2007 virtual machine.

Regards
Peter

 
Magento Community Magento Community
Magento Community
Magento Community
 
ogonkov
Guru
 
Total Posts:  582
Joined:  2009-03-25
Moscow, Russia
 

Very strange issue. I have the same as topic starter, when try add Modern Theme (on absolutely fresh Magento installation).

pear/PEAR requires package "pear/Archive_Tar" (recommended version 1.3.3)
magento-core/Mage_Pear_Helpers requires package "pear/PEAR" (version >= 1.6.2)
magento-core/Lib_Google_Checkout requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Mage_Core_Modules requires package "magento-core/Lib_Google_Checkout" (version >= 1.2.0version <= 1.3.3excluded versions1.3.3)
magento-core/Interface_Frontend_Default_Modern requires package "magento-core/Mage_Core_Modules" (version >= 1.3.2.2version <= 1.3.3excluded versions1.3.3)
magento-core/Lib_Js_Calendar requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Lib_Js_Prototype requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Lib_Js_Mage requires package "magento-core/Lib_Js_Prototype" (version >= 1.3.2version <= 1.3.3excluded versions1.3.3)
magento-core/Lib_ZF requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
magento-core/Lib_Varien requires package "magento-core/Lib_ZF" (version >= 1.7.2.4version <= 1.7.3excluded versions1.7.3)
magento-core/Lib_ZF_Locale requires package "magento-core/Mage_Pear_Helpers" (version >= 1.0.18800)
Install Errors
No valid packages found
PEAR ERROR
install failed

But after some time of searching solution, i’ll try add pear.php.net channel, have no success, but theme have install properly shut eye

downloading Interface_Frontend_Default_Modern-1.3.2.2.tgz ...
Starting to download Interface_Frontend_Default_Modern-1.3.2.2.tgz (654,851 bytes)
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ...
done654,851 bytes
downloading Mage_Core_Modules
-1.3.2.4.tgz ...
Starting to download Mage_Core_Modules-1.3.2.4.tgz (1,625,826 bytes)
...
done1,625,826 bytes
downloading Lib_Varien
-1.3.2.2.tgz ...
Starting to download Lib_Varien-1.3.2.2.tgz (112,925 bytes)
...
done112,925 bytes
downloading Lib_Google_Checkout
-1.2.0.tgz ...
Starting to download Lib_Google_Checkout-1.2.0.tgz (27,164 bytes)
...
done27,164 bytes
downloading Lib_Js_Calendar
-1.3.2.tgz ...
Starting to download Lib_Js_Calendar-1.3.2.tgz (23,873 bytes)
...
done23,873 bytes
downloading Lib_Js_Mage
-1.3.2.3.tgz ...
Starting to download Lib_Js_Mage-1.3.2.3.tgz (70,330 bytes)
...
done70,330 bytes
downloading Lib_Js_Prototype
-1.3.2.tgz ...
Starting to download Lib_Js_Prototype-1.3.2.tgz (220,016 bytes)
...
done220,016 bytes
downloading Lib_ZF
-1.7.2.4.tgz ...
Starting to download Lib_ZF-1.7.2.4.tgz (1,252,569 bytes)
...
done1,252,569 bytes
downloading Mage_Pear_Helpers
-1.0.18800.tgz ...
Starting to download Mage_Pear_Helpers-1.0.18800.tgz (9,225 bytes)
...
done9,225 bytes
downloading Lib_ZF_Locale
-1.7.2.2.tgz ...
Starting to download Lib_ZF_Locale-1.7.2.2.tgz (1,279,370 bytes)
...
done1,279,370 bytes
downloading PEAR
-1.9.0.tgz ...
Starting to download PEAR-1.9.0.tgz (291,634 bytes)
...
done291,634 bytes
downloading Archive_Tar
-1.3.3.tgz ...
Starting to download Archive_Tar-1.3.3.tgz (18,119 bytes)
...
done18,119 bytes
install ok
channel://pear.php.net/Archive_Tar-1.3.3
install okchannel://pear.php.net/PEAR-1.9.0
install okchannel://connect.magentocommerce.com/core/Mage_Pear_Helpers-1.0.18800
install okchannel://connect.magentocommerce.com/core/Lib_Google_Checkout-1.2.0
install okchannel://connect.magentocommerce.com/core/Lib_Js_Calendar-1.3.2
install okchannel://connect.magentocommerce.com/core/Lib_Js_Prototype-1.3.2
install okchannel://connect.magentocommerce.com/core/Lib_ZF_Locale-1.7.2.2
install okchannel://connect.magentocommerce.com/core/Lib_Js_Mage-1.3.2.3
install okchannel://connect.magentocommerce.com/core/Lib_ZF-1.7.2.4
install okchannel://connect.magentocommerce.com/core/Lib_Varien-1.3.2.2
install okchannel://connect.magentocommerce.com/core/Mage_Core_Modules-1.3.2.4
install okchannel://connect.magentocommerce.com/core/Interface_Frontend_Default_Modern-1.3.2.2
PEAROptional feature webinstaller available (PEAR's web-based installer)
PEAR: Optional feature gtkinstaller available (PEAR'
s PHP-GTK-based installer)
PEAROptional feature gtk2installer available (PEAR's PHP-GTK2-based installer)
PEAR: To install optional features use "pear install pear/PEAR#featurename"

I’m absolutely do nothing, amazing!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top